aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cnc
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/cnc')
-rw-r--r--recipes/cnc/openredalert/gcc43-fix.patch13
-rwxr-xr-xrecipes/cnc/openredalert/openredalert-launcher3
-rw-r--r--recipes/cnc/openredalert_r438.bb31
-rw-r--r--recipes/cnc/redalert-demo-gamedata.bb15
4 files changed, 62 insertions, 0 deletions
diff --git a/recipes/cnc/openredalert/gcc43-fix.patch b/recipes/cnc/openredalert/gcc43-fix.patch
new file mode 100644
index 0000000000..aa99d991b7
--- /dev/null
+++ b/recipes/cnc/openredalert/gcc43-fix.patch
@@ -0,0 +1,13 @@
+Index: openredalert-0.0+svnr438-r0/src/misc/Compression.h
+===================================================================
+--- openredalert-0.0+svnr438-r0.orig/src/misc/Compression.h 2008-09-21 15:20:33.000000000 +0200
++++ openredalert-0.0+svnr438-r0/src/misc/Compression.h 2008-09-21 15:21:10.000000000 +0200
+@@ -20,6 +20,8 @@
+
+ #include "SDL/SDL_types.h"
+
++#include <cstring>
++
+ /**
+ * Various decompression routines for format80, format40, and
+ * format20 type graphics
diff --git a/recipes/cnc/openredalert/openredalert-launcher b/recipes/cnc/openredalert/openredalert-launcher
new file mode 100755
index 0000000000..4e5dad4bb6
--- /dev/null
+++ b/recipes/cnc/openredalert/openredalert-launcher
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+( cd /usr/share/games/redalert && ./openredalert )
diff --git a/recipes/cnc/openredalert_r438.bb b/recipes/cnc/openredalert_r438.bb
new file mode 100644
index 0000000000..098f293b2e
--- /dev/null
+++ b/recipes/cnc/openredalert_r438.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Game engine to run Red Alert 1"
+LICENSE = "GPLv2"
+
+DEPENDS = "virtual/libsdl libsdl-mixer"
+
+SRC_URI = "http://openredalert.googlecode.com/files/openredalert-${PV}-src.tar.gz \
+ file://gcc43-fix.patch;patch=1 \
+ file://openredalert-launcher"
+
+PR = "r1"
+
+S = "${WORKDIR}"
+
+CFLAGS_append = " -I. -I${STAGING_INCDIR}"
+
+do_compile() {
+ cd ${S}/src ; cp ${S}/makefile .
+ oe_runmake -e
+}
+
+do_install() {
+ install -d ${D}/${datadir}/games/redalert/
+ cp -pPr ${S}/data ${D}/${datadir}/games/redalert/
+ install -m 0755 ${S}/src/openredalert ${D}/${datadir}/games/redalert/
+
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/openredalert-launcher ${D}/${bindir}
+}
+
+FILES_${PN} += "${datadir}/games/redalert/"
+FILES_${PN}-dbg += "${datadir}/games/redalert/.debug"
diff --git a/recipes/cnc/redalert-demo-gamedata.bb b/recipes/cnc/redalert-demo-gamedata.bb
new file mode 100644
index 0000000000..1aa5722647
--- /dev/null
+++ b/recipes/cnc/redalert-demo-gamedata.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Red Alert Demo game data"
+LICENSE = "shareware"
+
+SRC_URI = "ftp://ftp.westwood.com/pub/redalert/previews/demo/ra95demo.zip"
+
+do_install() {
+ install -d ${D}/${datadir}/games/redalert/data/mix
+ cp ${WORKDIR}/ra95demo/INSTALL/MAIN.MIX ${D}/${datadir}/games/redalert/data/mix/main.mix
+ cp ${WORKDIR}/ra95demo/INSTALL/REDALERT.MIX ${D}/${datadir}/games/redalert/data/mix/redalert.mix
+}
+
+
+PACKAGE_ARCH = "all"
+FILES_${PN} += "${datadir}/games/redalert/"
+