aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/comprec/comprec_0.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/comprec/comprec_0.01.bb')
-rw-r--r--recipes/comprec/comprec_0.01.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/comprec/comprec_0.01.bb b/recipes/comprec/comprec_0.01.bb
new file mode 100644
index 0000000000..3b0e858385
--- /dev/null
+++ b/recipes/comprec/comprec_0.01.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "An MP3 command line encoder"
+HOMEPAGE = "http://unimut.fsk.uni-heidelberg.de/demi/comprec/index.html"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+SRC_URI = "http://unimut.fsk.uni-heidelberg.de/demi/comprec/comprec-${PV}.tar.gz \
+ file://makefile.patch;patch=1"
+
+export AS = "${TARGET_PREFIX}as"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 shine ${D}${bindir}/shine
+}