aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/confuse/confuse_2.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/confuse/confuse_2.5.bb')
-rw-r--r--recipes/confuse/confuse_2.5.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/confuse/confuse_2.5.bb b/recipes/confuse/confuse_2.5.bb
new file mode 100644
index 0000000000..572bcd334c
--- /dev/null
+++ b/recipes/confuse/confuse_2.5.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Library for parsing configuration files."
+HOMEPAGE = "http://www.nongnu.org/confuse/"
+LICENSE = "LGPL"
+SECTION = "libs"
+
+SRC_URI = "http://download.savannah.gnu.org/releases/confuse/confuse-${PV}.tar.gz \
+ file://build-only-library.patch;patch=1"
+S = "${WORKDIR}/confuse-${PV}"
+
+inherit autotools binconfig pkgconfig lib_package
+
+EXTRA_OECONF = "--enable-shared"
+
+do_stage() {
+ autotools_stage_all
+}
+