aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/connman/files/use_nm_in_cross_compiling.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/connman/files/use_nm_in_cross_compiling.patch')
-rw-r--r--recipes/connman/files/use_nm_in_cross_compiling.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/connman/files/use_nm_in_cross_compiling.patch b/recipes/connman/files/use_nm_in_cross_compiling.patch
new file mode 100644
index 0000000000..e9f2b29e3e
--- /dev/null
+++ b/recipes/connman/files/use_nm_in_cross_compiling.patch
@@ -0,0 +1,17 @@
+Index: git/src/Makefile.am
+===================================================================
+--- git.orig/src/Makefile.am 2008-09-18 16:48:44.000000000 +0800
++++ git/src/Makefile.am 2008-09-18 16:49:54.000000000 +0800
+@@ -44,7 +44,11 @@
+ MAINTAINERCLEANFILES = Makefile.in
+
+ connman.exp:
+- nm -B *.o | awk '{ print $$3 }' | sort -u | grep -E -e '^connman_' > $@
++ if test -n $$host ; then \
++ $(host)-nm -B *.o | awk '{ print $$3 }' | sort -u | grep -E -e '^connman_' > $@ ;\
++ else \
++ nm -B *.o | awk '{ print $$3 }' | sort -u | grep -E -e '^connman_' > $@ ;\
++ fi
+
+ connman.ver: connman.exp
+ echo "{ global:" > $@