aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cron/cron_3.0pl1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/cron/cron_3.0pl1.bb')
-rw-r--r--recipes/cron/cron_3.0pl1.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/cron/cron_3.0pl1.bb b/recipes/cron/cron_3.0pl1.bb
new file mode 100644
index 0000000000..f7c2ccc6ba
--- /dev/null
+++ b/recipes/cron/cron_3.0pl1.bb
@@ -0,0 +1,34 @@
+SECTION = "base"
+DESCRIPTION = "Vixie cron."
+LICENSE = "cron"
+PR ="r8"
+DEPENDS += "install-native"
+
+SRC_URI = "http://ibiblio.org/pub/Linux/system/daemons/cron/cron${PV}.tar.gz \
+ file://nonrootinstall.patch;patch=1 \
+ file://time.patch;patch=1 \
+ file://init"
+S = "${WORKDIR}/cron${PV}"
+
+INITSCRIPT_NAME = "cron"
+INITSCRIPT_PARAMS = "defaults"
+inherit update-rc.d
+
+CFLAGS_append = " -I${S} -DSYS_TIME_H=0"
+do_install () {
+ install -d ${D}${sbindir} ${D}${bindir}
+ install -d ${D}${sysconfdir}/init.d/
+ install -d ${D}/var/cron/tabs
+ install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/cron
+ oe_runmake 'DESTDIR=${D}' install
+ chmod ugo+rx ${D}${sbindir}/* ${D}${bindir}/*
+}
+pkg_postinst() {
+ update-rc.d cron defaults 65
+}
+
+pkg_postrm() {
+ update-rc.d cron remove
+}
+
+