aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dbus/dbus-c++_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/dbus/dbus-c++_svn.bb')
-rw-r--r--recipes/dbus/dbus-c++_svn.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/dbus/dbus-c++_svn.bb b/recipes/dbus/dbus-c++_svn.bb
new file mode 100644
index 0000000000..5be58741dc
--- /dev/null
+++ b/recipes/dbus/dbus-c++_svn.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "C++ bindings for dbus"
+LICENSE = "LGPL"
+SECTION = "libs"
+DEPENDS = "dbus dbus-c++-native expat"
+
+SRC_URI = "svn://dev.openwengo.org/svn/openwengo/wengophone-ng/branches/wengophone-dbus-api/libs;module=dbus;proto=http"
+# file://fix-linking.patch;patch=1"
+S = "${WORKDIR}/dbus"
+
+inherit autotools pkgconfig
+
+do_compile_prepend() {
+ find . -name "Makefile.am" |xargs sed -i -e 's,$(top_builddir)/tools/dbusxx-xml2cpp,dbusxx-xml2cpp,'
+}
+
+FILES_${PN}-dbg += "${bindir}/dbusxx-xml2cpp ${bindir}/dbusxx-introspect"
+FILES_${PN}-dev += "${bindir}/.dev"
+FILES_${PN} = "${libdir}/*.so.*"
+