aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dgen/dgen-sdl_1.23.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/dgen/dgen-sdl_1.23.bb')
-rw-r--r--recipes/dgen/dgen-sdl_1.23.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/dgen/dgen-sdl_1.23.bb b/recipes/dgen/dgen-sdl_1.23.bb
new file mode 100644
index 0000000000..e682a3163d
--- /dev/null
+++ b/recipes/dgen/dgen-sdl_1.23.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "DGen/SDL is a Sega Genesis/Mega-drive emulator."
+DEPENDS = "virtual/libsdl"
+SECTION = "x11/games"
+LICENSE = "BSD"
+
+SRC_URI = "\
+ http://pknet.com/~joe/${PN}-${PV}.tar.gz \
+ file://fix-configure-and-make.patch;patch=1 \
+"
+
+inherit autotools
+
+EXTRA_OECONF = " --disable-sdltest --without-x --without-opengl --without-nasm --without-mmx --without-star"
+
+do_compile () {
+ oe_runmake 'HOSTCC=${BUILD_CC}'
+}