aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dhcp-forwarder/dhcp-forwarder_0.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/dhcp-forwarder/dhcp-forwarder_0.7.bb')
-rw-r--r--recipes/dhcp-forwarder/dhcp-forwarder_0.7.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/dhcp-forwarder/dhcp-forwarder_0.7.bb b/recipes/dhcp-forwarder/dhcp-forwarder_0.7.bb
new file mode 100644
index 0000000000..8cf060e287
--- /dev/null
+++ b/recipes/dhcp-forwarder/dhcp-forwarder_0.7.bb
@@ -0,0 +1,26 @@
+SECTION = "console/network"
+DESCRIPTION = "This program is used to forward DHCP and BOOTP messages between two \
+ networks with different broadcast domains. \
+ It works better with ppp - and especially with ipsec over ppp - than \
+ dhcp-relay from ISC and has a smaller foot print."
+HOMEPAGE = "http://www.nongnu.org/dhcp-fwd/"
+LICENSE = "GPLv2"
+
+SRC_URI = "http://savannah.nongnu.org/download/dhcp-fwd/dhcp-forwarder-${PV}.tar.bz2 \
+ file://init \
+ file://dhcp-fwd.cfg"
+
+inherit autotools update-rc.d
+
+EXTRA_OECONF="--disable-dietlibc"
+
+INITSCRIPT_NAME="dhcp-forwarder"
+INITSCRIPT_PARAMS="defaults"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/dhcp-forwarder
+ install -m 0644 ${WORKDIR}/dhcp-fwd.cfg ${D}${sysconfdir}
+}
+
+CONFFILES_${PN}_nylon = "${sysconfdir}/dhcp-fwd.cfg"