aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/directfb/++dfb_1.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/directfb/++dfb_1.0.0.bb')
-rw-r--r--recipes/directfb/++dfb_1.0.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/directfb/++dfb_1.0.0.bb b/recipes/directfb/++dfb_1.0.0.bb
new file mode 100644
index 0000000000..7c4aea3920
--- /dev/null
+++ b/recipes/directfb/++dfb_1.0.0.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "A C++ Wrapper for the directfb framebuffer library."
+HOMEPAGE = "http://directfb.org"
+SECTION = "libs"
+DEPENDS = "directfb"
+LICENSE = "LGPL"
+
+SRC_URI = "http://www.directfb.org/downloads/Extras/++DFB-${PV}.tar.gz"
+S = "${WORKDIR}/++DFB-${PV}"
+RV = "0.9-25"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+FILES_++dfb_append = " ${libdir}/*.so*"