aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dmalloc/dmalloc_5.5.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/dmalloc/dmalloc_5.5.2.bb')
-rw-r--r--recipes/dmalloc/dmalloc_5.5.2.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/dmalloc/dmalloc_5.5.2.bb b/recipes/dmalloc/dmalloc_5.5.2.bb
new file mode 100644
index 0000000000..c91152b537
--- /dev/null
+++ b/recipes/dmalloc/dmalloc_5.5.2.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Debug Malloc Library"
+SECTION = "libs/devel"
+HOMEPAGE = "http://dmalloc.com"
+LICENSE = "CCSA"
+
+SRC_URI = "\
+ http://dmalloc.com/releases/dmalloc-${PV}.tgz \
+ file://configure-pagesize-HACK.patch;patch=1 \
+# HACK we ship a preconfigured conf.h since otherwise it misses a whole lot of stuff and compilation fails.
+# TODO find out why and get rid of it
+ file://conf.h \
+"
+inherit autotools pkgconfig
+
+do_configure_append() {
+ install -m 0644 ${WORKDIR}/conf.h ${S}
+}
+
+do_stage() {
+ oe_libinstall -a libdmalloc ${STAGING_LIBDIR}
+}
+
+do_install() {
+ :
+}