aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/driftnet/driftnet_0.1.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/driftnet/driftnet_0.1.6.bb')
-rw-r--r--recipes/driftnet/driftnet_0.1.6.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/driftnet/driftnet_0.1.6.bb b/recipes/driftnet/driftnet_0.1.6.bb
new file mode 100644
index 0000000000..8a272792a0
--- /dev/null
+++ b/recipes/driftnet/driftnet_0.1.6.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Driftnet watches network traffic, and picks out and displays JPEG and GIF \
+images for display. It is an horrific invasion of privacy and shouldn't be used \
+by anyone anywhere. It can also extract MPEG audio data from the network and \
+play it."
+SECTION = "net"
+PRIORITY = "optional"
+
+DEPENDS = "libpcap jpeg libungif gtk+ libgpewidget"
+PV = "0.1.6"
+
+SRC_URI = "http://www.ex-parrot.com/~chris/driftnet/${PN}-${PV}.tar.gz \
+ file://arm.patch;patch=1"
+
+S = "${WORKDIR}/driftnet-${PV}"
+
+inherit autotools
+
+do_compile() {
+ oe_runmake STAGING_INCDIR="${STAGING_INCDIR}"
+}
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0744 driftnet ${D}/${bindir}/
+}