aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dsniff/dsniff_2.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/dsniff/dsniff_2.3.bb')
-rw-r--r--recipes/dsniff/dsniff_2.3.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/dsniff/dsniff_2.3.bb b/recipes/dsniff/dsniff_2.3.bb
new file mode 100644
index 0000000000..14da908b57
--- /dev/null
+++ b/recipes/dsniff/dsniff_2.3.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "dsniff is a collection of tools for network auditing and penetration testing."
+SECTION = "console/network"
+HOMEPAGE = "http://www.monkey.org/~dugsong/dsniff/"
+AUTHOR = "Dug Song <dugsong@monkey.org>"
+LICENSE = "BSD"
+PR = "r2"
+
+# There is a significant API change beween 1.0.2a of libnet and
+# 1.1.x, dsniff will only work with the older and there is no
+# updated version of dnsniff.
+DEPENDS = "virtual/db libpcap libnet-1.0 libnids openssl"
+
+SRC_URI = "\
+ http://www.monkey.org/~dugsong/dsniff/dsniff-${PV}.tar.gz \
+ file://configure.patch;patch=1 \
+"
+
+inherit autotools
+
+EXTRA_OECONF = "\
+ --without-x --with-db=${STAGING_LIBDIR}/.. \
+ --with-libpcap=${STAGING_LIBDIR}/.. \
+ --with-libnet=${STAGING_LIBDIR}/.. \
+ --with-libnids=${STAGING_LIBDIR}/.. \
+ --with-openssl=${STAGING_LIBDIR}/.. \
+"
+EXTRA_OEMAKE = "'install_prefix=${D}'"
+
+CFLAGS =+ "-I${S}/missing"
+LDFLAGS += "-lresolv"