aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/e17/entrance_0.9.0.010.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/e17/entrance_0.9.0.010.bb')
-rw-r--r--recipes/e17/entrance_0.9.0.010.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/e17/entrance_0.9.0.010.bb b/recipes/e17/entrance_0.9.0.010.bb
new file mode 100644
index 0000000000..f9dd5e49ce
--- /dev/null
+++ b/recipes/e17/entrance_0.9.0.010.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "Entrance is the Enlightenment login manager"
+LICENSE = "MIT BSD"
+# can also use pam and crypt
+DEPENDS = "evas ecore edje esmart bash keylaunch xserver-common login-manager"
+RDEPENDS += "glibc-gconv-iso8859-1 entrance-themes"
+PR = "r2"
+
+inherit e
+
+SRC_URI += "\
+ file://config-db.patch;patch=1 \
+ file://allow-missing-xsession.patch;patch=1 \
+ file://run-Xinit.patch;patch=1 \
+ file://fix-auth-mode.patch;patch=1 \
+ file://use-bash.patch;patch=1 \
+ file://Sessions"
+
+S = "${WORKDIR}/entrance"
+
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
+ --with-xsession=/etc/X11/Xsession \
+ --with-auth-mode=0"
+
+FILES_${PN}-dbg += "${libexecdir}/entrance/.debug/*"
+
+do_install_append() {
+ install -d ${D}/etc/X11/Xsession.d
+ install -d ${D}/etc/X11/Sessions
+
+ install -m 755 ${WORKDIR}/Sessions/* ${D}/etc/X11/Sessions
+
+ install -d ${D}/etc/X11/login-managers/
+ mv ${D}/etc/init.d/entrance ${D}/etc/X11/login-managers/entrance
+}