aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ekiga
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ekiga')
-rw-r--r--recipes/ekiga/ptlib_2.8.2.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes/ekiga/ptlib_2.8.2.bb b/recipes/ekiga/ptlib_2.8.2.bb
new file mode 100644
index 0000000000..20bc20bee0
--- /dev/null
+++ b/recipes/ekiga/ptlib_2.8.2.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Portable Tools Libary"
+LICENSE = "MPL"
+
+inherit gnome
+
+DEPENDS += "libgsm openldap openssl expat virtual/libsdl alsa-lib"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/opalvoip/ptlib-${PV}.tar.bz2;name=ptlib \
+"
+SRC_URI[ptlib.md5sum] = "3248cbea1af92439a10a4ef15824e9e3"
+SRC_URI[ptlib.sha256sum] = "5e4518710e6f7daebe93581c388ef37c56fa3a1529b1ad48be86213ab3f3b8c7"
+
+EXTRA_OECONF = " --enable-exceptions "
+
+do_configure() {
+ libtoolize --force
+ gnu-configize
+ oe_runconf
+}
+
+do_compile_append() {
+ sed -i -e s:${STAGING_DIR_TARGET}::g \
+ -e s:/${TARGET_SYS}::g \
+ ptlib.pc
+}
+
+do_install_append() {
+ chmod +x ${D}${libdir}/*
+}
+
+FILES_${PN} += "${libdir}/ptlib-${PV}/*/*/*.so"
+
+