aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ekiga
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ekiga')
-rw-r--r--recipes/ekiga/ekiga/static-fix.diff45
-rw-r--r--recipes/ekiga/ekiga_3.0.2.bb26
-rw-r--r--recipes/ekiga/ekiga_3.1.0.bb20
-rw-r--r--recipes/ekiga/opal/configure.diff32
-rw-r--r--recipes/ekiga/opal_3.4.4.bb26
-rw-r--r--recipes/ekiga/opal_3.5.2.bb29
-rw-r--r--recipes/ekiga/ptlib_2.4.4.bb30
-rw-r--r--recipes/ekiga/ptlib_2.5.2.bb30
8 files changed, 238 insertions, 0 deletions
diff --git a/recipes/ekiga/ekiga/static-fix.diff b/recipes/ekiga/ekiga/static-fix.diff
new file mode 100644
index 0000000000..3c345be5c4
--- /dev/null
+++ b/recipes/ekiga/ekiga/static-fix.diff
@@ -0,0 +1,45 @@
+--- /tmp/misc.cpp 2009-01-18 21:24:26.000000000 +0100
++++ ekiga-3.0.2/src/gui/misc.cpp 2009-01-18 21:24:47.000000000 +0100
+@@ -75,42 +75,6 @@
+ return button;
+ }
+
+-
+-
+-/* This function overrides from a pwlib function */
+-#ifndef STATIC_LIBS_USED
+-static gboolean
+-assert_error_msg (gpointer data)
+-{
+- GtkWidget *main_window = NULL;
+-
+- main_window = GnomeMeeting::Process ()->GetMainWindow ();
+-
+-
+- //gdk_threads_enter ();
+- std::cout << "FIXME" << std::endl << std::flush;
+- //FIXME Should use a signal in the runtime.
+- gnomemeeting_error_dialog (GTK_WINDOW (main_window),
+- _("Error"),
+- "%s", (gchar *) data);
+- //gdk_threads_leave ();
+-
+- return FALSE;
+-}
+-
+-
+-void
+-PAssertFunc (G_GNUC_UNUSED const char *file,
+- G_GNUC_UNUSED int line,
+- G_GNUC_UNUSED const char *className,
+- const char *msg)
+-{
+- g_idle_add_full (G_PRIORITY_HIGH, assert_error_msg, g_strdup (msg), g_free);
+-}
+-#endif
+-
+-
+-
+ PString
+ gnomemeeting_pstring_cut (PString s)
+ {
diff --git a/recipes/ekiga/ekiga_3.0.2.bb b/recipes/ekiga/ekiga_3.0.2.bb
new file mode 100644
index 0000000000..30f33c0ab8
--- /dev/null
+++ b/recipes/ekiga/ekiga_3.0.2.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Gnome videoconferencing application"
+LICENSE = "GPLv2"
+
+PR = "r1"
+
+ARM_INSTRUCTION_SET = "arm"
+
+inherit gnome
+DEPENDS += " avahi libnotify eds-dbus libgnome gtkmm libsigc++-2.0 gstreamer opal ptlib"
+RDEPENDS += "opal ptlib"
+
+SRC_URI = "http://www.ekiga.org/admin/downloads/latest/sources/ekiga_${PV}/ekiga-${PV}.tar.gz \
+ file://static-fix.diff;patch=1"
+
+EXTRA_OECONF = " --enable-static-libs --disable-gdu --disable-scrollkeeper "
+
+CFLAGS_append = " -DSTATIC_LIBS_USED "
+CXXFLAGS_append = " -DSTATIC_LIBS_USED "
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
+ find ${S} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
+}
+
+FILES_${PN} += "${datadir}/dbus-1 ${datadir}/icons"
+
diff --git a/recipes/ekiga/ekiga_3.1.0.bb b/recipes/ekiga/ekiga_3.1.0.bb
new file mode 100644
index 0000000000..38695903c1
--- /dev/null
+++ b/recipes/ekiga/ekiga_3.1.0.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Gnome videoconferencing application"
+LICENSE = "GPLv2"
+
+PR = "r3"
+
+ARM_INSTRUCTION_SET = "arm"
+
+inherit gnome
+DEPENDS += " avahi libnotify eds-dbus libgnome gtkmm libsigc++-2.0 gstreamer gst-plugins-good gst-plugins-base gst-plugins-bad opal ptlib gnome-doc-utils"
+RDEPENDS += "gst-plugin-app gst-plugin-video4linux2 opal ptlib"
+
+EXTRA_OECONF = "--enable-static-libs --disable-ldap --disable-gnome --enable-gstreamer --disable-gdu --disable-scrollkeeper "
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
+ find ${S} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
+}
+
+FILES_${PN} += "${datadir}/dbus-1 ${datadir}/icons"
+
diff --git a/recipes/ekiga/opal/configure.diff b/recipes/ekiga/opal/configure.diff
new file mode 100644
index 0000000000..46610db05d
--- /dev/null
+++ b/recipes/ekiga/opal/configure.diff
@@ -0,0 +1,32 @@
+--- /tmp/opal.m4 2009-01-18 19:24:21.000000000 +0100
++++ opal-3.4.4/opal.m4 2009-01-18 19:25:19.000000000 +0100
+@@ -813,27 +813,9 @@
+ if test "x$opal_gsm" = "xyes"; then
+ AC_MSG_CHECKING(if system GSM library has WAV49)
+ old_LIBS=$LIBS
+- opal_gsm=no
++ opal_gsm=yes
+
+ LIBS="$LIBS -lgsm"
+- AC_RUN_IFELSE(
+- [AC_LANG_PROGRAM([[
+- #include <gsm.h>
+- ]],[[
+- int option = 0;
+- gsm handle = gsm_create();
+- return (gsm_option(handle, GSM_OPT_WAV49, &option) == -1) ? 1 : 0;
+- ]])], opal_gsm=yes)
+- LIBS=$old_LIBS
+- AC_MSG_RESULT($opal_gsm)
+-
+- if test "x${opal_gsm}" = "xyes" ; then
+- GSM_CLFAGS=""
+- GSM_LIBS="-lgsm"
+- fi
+- OPAL_MSG_CHECK([System GSM], [$opal_gsm])
+- fi
+- AS_IF([test AS_VAR_GET([opal_gsm]) = yes], [$1], [$2])[]
+ ])
+
+
+
diff --git a/recipes/ekiga/opal_3.4.4.bb b/recipes/ekiga/opal_3.4.4.bb
new file mode 100644
index 0000000000..2b7cd14af2
--- /dev/null
+++ b/recipes/ekiga/opal_3.4.4.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Open Phone Abstraction Library, implementation of the ITU H.323 teleconferencing protocol, and successor of the openh323 library."
+LICENSE = "MPL"
+
+inherit gnome
+
+DEPENDS += " ffmpeg ptlib virtual/libsdl openldap"
+
+SRC_URI = "http://www.ekiga.org/admin/downloads/latest/sources/ekiga_3.0.2/opal-${PV}.tar.bz2 \
+ file://configure.diff;patch=1 \
+ "
+
+EXTRA_OECONF = "--enable-localgsm --disable-spandsp "
+
+do_configure() {
+ libtoolize --force
+ gnu-configize
+ oe_runconf
+}
+
+FILES_${PN} += "${libdir}/opal-${PV}/*/*.so ${libdir}/opal-${PV}/*/*/*.so"
+FILES_${PN}-dbg += "${libdir}/opal-${PV}/*/.debug ${libdir}/opal-${PV}/*/*/.debug"
+
+do_stage() {
+ autotools_stage_all
+}
+
diff --git a/recipes/ekiga/opal_3.5.2.bb b/recipes/ekiga/opal_3.5.2.bb
new file mode 100644
index 0000000000..ea4685d4c5
--- /dev/null
+++ b/recipes/ekiga/opal_3.5.2.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Open Phone Abstraction Library, implementation of the ITU H.323 teleconferencing protocol, and successor of the openh323 library."
+LICENSE = "MPL"
+
+PR = "r1"
+
+inherit gnome
+
+DEPENDS += " ffmpeg ptlib virtual/libsdl openldap"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/opalvoip/opal-${PV}.tar.bz2 \
+ file://configure.diff;patch=1 \
+ "
+
+EXTRA_OECONF = "--enable-localgsm --disable-spandsp "
+ARM_INSTRUCTION_SET = "arm"
+
+do_configure() {
+ libtoolize --force
+ gnu-configize
+ oe_runconf
+}
+
+FILES_${PN} += "${libdir}/opal-${PV}/*/*.so ${libdir}/opal-${PV}/*/*/*.so"
+FILES_${PN}-dbg += "${libdir}/opal-${PV}/*/.debug ${libdir}/opal-${PV}/*/*/.debug"
+
+do_stage() {
+ autotools_stage_all
+}
+
diff --git a/recipes/ekiga/ptlib_2.4.4.bb b/recipes/ekiga/ptlib_2.4.4.bb
new file mode 100644
index 0000000000..f5598d31ab
--- /dev/null
+++ b/recipes/ekiga/ptlib_2.4.4.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Portable Tools Libary"
+LICENSE = "MPL"
+
+inherit gnome
+
+DEPENDS += "libgsm openldap openssl expat virtual/libsdl alsa-lib"
+
+SRC_URI = "http://www.ekiga.org/admin/downloads/latest/sources/ekiga_3.0.2/ptlib-${PV}.tar.bz2"
+
+do_configure() {
+ libtoolize --force
+ gnu-configize
+ oe_runconf
+}
+
+do_compile_append() {
+ sed -i -e s:${STAGING_DIR_TARGET}::g \
+ -e s:/${TARGET_SYS}::g \
+ ptlib.pc
+}
+
+FILES_${PN} += "${libdir}/ptlib-${PV}/*/*/*.so"
+
+do_stage() {
+ autotools_stage_all
+}
+
+
+
+
diff --git a/recipes/ekiga/ptlib_2.5.2.bb b/recipes/ekiga/ptlib_2.5.2.bb
new file mode 100644
index 0000000000..93a3bd8c96
--- /dev/null
+++ b/recipes/ekiga/ptlib_2.5.2.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Portable Tools Libary"
+LICENSE = "MPL"
+
+inherit gnome
+
+DEPENDS += "libgsm openldap openssl expat virtual/libsdl alsa-lib"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/opalvoip/ptlib-${PV}.tar.bz2"
+
+do_configure() {
+ libtoolize --force
+ gnu-configize
+ oe_runconf
+}
+
+do_compile_append() {
+ sed -i -e s:${STAGING_DIR_TARGET}::g \
+ -e s:/${TARGET_SYS}::g \
+ ptlib.pc
+}
+
+FILES_${PN} += "${libdir}/ptlib-${PV}/*/*/*.so"
+
+do_stage() {
+ autotools_stage_all
+}
+
+
+
+