aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/elfkickers/elfkickers_2.0a.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/elfkickers/elfkickers_2.0a.bb')
-rw-r--r--recipes/elfkickers/elfkickers_2.0a.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/elfkickers/elfkickers_2.0a.bb b/recipes/elfkickers/elfkickers_2.0a.bb
new file mode 100644
index 0000000000..d7aab81504
--- /dev/null
+++ b/recipes/elfkickers/elfkickers_2.0a.bb
@@ -0,0 +1,32 @@
+HOMEPAGE = "http://www.muppetlabs.com/~breadbox/software/elfkickers.html"
+LICENSE = "GPL"
+PRIORITY = "optional"
+SECTION = "devel"
+
+SRC_URI = "http://www.muppetlabs.com/~breadbox/pub/software/ELFkickers-${PV}.tar.gz \
+ file://gentoo.patch;patch=1 \
+ file://mjn3-sstrip.patch;patch=1"
+S = "${WORKDIR}/ELFkickers"
+
+ELFPKGS = "ebfc elfls elftoc \
+ rebind sstrip"
+
+PACKAGES = "${PN}-dbg ${ELFPKGS} ${PN}"
+FILES_ebfc = "${bindir}/ebfc"
+FILES_elfls = "${bindir}/elfls"
+FILES_elftoc = "${bindir}/elftoc"
+FILES_rebind = "${bindir}/rebind"
+FILES_sstrip = "${bindir}/sstrip"
+
+do_compile () {
+ for d in ${ELFPKGS}; do
+ oe_runmake -C $d || exit 1
+ done
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ for d in ${ELFPKGS}; do
+ install -m 0755 $d/$d ${D}${bindir}/ || exit 1
+ done
+}