aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/elfutils/elfutils-0.127/warnings.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/elfutils/elfutils-0.127/warnings.patch')
-rw-r--r--recipes/elfutils/elfutils-0.127/warnings.patch149
1 files changed, 149 insertions, 0 deletions
diff --git a/recipes/elfutils/elfutils-0.127/warnings.patch b/recipes/elfutils/elfutils-0.127/warnings.patch
new file mode 100644
index 0000000000..454706de4b
--- /dev/null
+++ b/recipes/elfutils/elfutils-0.127/warnings.patch
@@ -0,0 +1,149 @@
+Index: elfutils-0.127/configure.ac
+===================================================================
+--- elfutils-0.127.orig/configure.ac 2007-04-19 07:55:07.000000000 +0100
++++ elfutils-0.127/configure.ac 2008-03-26 10:45:54.000000000 +0000
+@@ -55,6 +55,10 @@
+ dnl Add all the languages for which translations are available.
+ ALL_LINGUAS=
+
++if test X"$CFLAGS" = X; then
++ CFLAGS="-Wall -Werror -g -O2"
++fi
++
+ AC_PROG_CC
+ AC_PROG_RANLIB
+ AC_PROG_YACC
+Index: elfutils-0.127/lib/Makefile.am
+===================================================================
+--- elfutils-0.127.orig/lib/Makefile.am 2006-04-11 21:52:05.000000000 +0100
++++ elfutils-0.127/lib/Makefile.am 2008-03-26 10:45:54.000000000 +0000
+@@ -30,7 +30,7 @@
+ else
+ AM_CFLAGS =
+ endif
+-AM_CFLAGS += -fpic -Wall -Wshadow -Werror -Wunused -Wextra $($(*F)_CFLAGS)
++AM_CFLAGS += -fpic -Wshadow -Wunused $($(*F)_CFLAGS)
+ INCLUDES = -I$(srcdir)/../libelf -I..
+
+ noinst_LIBRARIES = libeu.a
+Index: elfutils-0.127/libasm/Makefile.am
+===================================================================
+--- elfutils-0.127.orig/libasm/Makefile.am 2006-08-29 20:31:57.000000000 +0100
++++ elfutils-0.127/libasm/Makefile.am 2008-03-26 10:45:54.000000000 +0000
+@@ -30,7 +30,7 @@
+ else
+ AM_CFLAGS =
+ endif
+-AM_CFLAGS += -std=gnu99 -Wall -Wshadow -Werror -Wunused -Wextra -Wformat=2
++AM_CFLAGS += -std=gnu99 -Wshadow -Wunused -Wformat=2
+ INCLUDES = -I. -I$(srcdir) -I.. \
+ -I$(top_srcdir)/libelf -I$(top_srcdir)/libebl -I$(top_srcdir)/libdw\
+ -I$(top_srcdir)/lib
+Index: elfutils-0.127/libcpu/Makefile.am
+===================================================================
+--- elfutils-0.127.orig/libcpu/Makefile.am 2006-04-11 21:52:05.000000000 +0100
++++ elfutils-0.127/libcpu/Makefile.am 2008-03-26 10:45:54.000000000 +0000
+@@ -25,7 +25,7 @@
+ ## <http://www.openinventionnetwork.com>.
+ ##
+ DEFS = -D_GNU_SOURCE -DHAVE_CONFIG_H
+-AM_CFLAGS = -Wall -Wshadow -Werror -Wextra -Wformat=2 -Wunused
++AM_CFLAGS = -Wshadow -Wformat=2 -Wunused
+ INCLUDES = -I$(srcdir)
+
+ noinst_LIBRARIES = libcpu_i386.a
+Index: elfutils-0.127/libdw/Makefile.am
+===================================================================
+--- elfutils-0.127.orig/libdw/Makefile.am 2007-04-05 11:26:50.000000000 +0100
++++ elfutils-0.127/libdw/Makefile.am 2008-03-26 10:45:54.000000000 +0000
+@@ -33,7 +33,7 @@
+ if BUILD_STATIC
+ AM_CFLAGS += -fpic
+ endif
+-AM_CFLAGS += -Wall -Werror -Wshadow -Wunused -Wformat=2 -Wextra -std=gnu99
++AM_CFLAGS += -Wshadow -Wunused -Wformat=2 -std=gnu99
+ INCLUDES = -I. -I$(srcdir) -I$(srcdir)/../libelf -I.. -I$(srcdir)/../lib
+ VERSION = 1
+
+Index: elfutils-0.127/libebl/Makefile.am
+===================================================================
+--- elfutils-0.127.orig/libebl/Makefile.am 2007-04-05 10:12:36.000000000 +0100
++++ elfutils-0.127/libebl/Makefile.am 2008-03-26 10:45:54.000000000 +0000
+@@ -30,7 +30,7 @@
+ else
+ AM_CFLAGS =
+ endif
+-AM_CFLAGS += -fpic -Wall -Wshadow -Werror -Wunused -Wextra -Wformat=2 \
++AM_CFLAGS += -fpic -Wshadow -Wunused -Wformat=2 \
+ -std=gnu99
+
+ INCLUDES = -I$(srcdir) -I$(top_srcdir)/libelf -I$(top_srcdir)/libdw \
+Index: elfutils-0.127/libelf/Makefile.am
+===================================================================
+--- elfutils-0.127.orig/libelf/Makefile.am 2007-04-05 10:12:36.000000000 +0100
++++ elfutils-0.127/libelf/Makefile.am 2008-03-26 10:45:54.000000000 +0000
+@@ -33,7 +33,7 @@
+ if BUILD_STATIC
+ AM_CFLAGS += -fpic
+ endif
+-AM_CFLAGS += -Wall -Wshadow -Werror -Wunused -Wextra -Wformat=2 -std=gnu99 \
++AM_CFLAGS += -Wshadow -Wunused -Wformat=2 -std=gnu99 \
+ $($(*F)_CFLAGS)
+ INCLUDES = -I$(srcdir) -I$(top_srcdir)/lib -I..
+ GCC_INCLUDE = -I$(shell $(CC) -print-file-name=include)
+Index: elfutils-0.127/tests/Makefile.am
+===================================================================
+--- elfutils-0.127.orig/tests/Makefile.am 2007-04-18 21:44:32.000000000 +0100
++++ elfutils-0.127/tests/Makefile.am 2008-03-26 10:45:54.000000000 +0000
+@@ -26,11 +26,11 @@
+ ##
+ DEFS = -DHAVE_CONFIG_H -D_GNU_SOURCE
+ if MUDFLAP
+-AM_CFLAGS = -Wall -Werror -Wextra -std=gnu99 -fmudflap\
++AM_CFLAGS = -std=gnu99 -fmudflap\
+ $(if $($(*F)_no_Wformat),-Wno-format,-Wformat=2)
+ BUILD_RPATH = \$$ORIGIN/../backends
+ else
+-AM_CFLAGS = -Wall -Werror -Wextra -std=gnu99 \
++AM_CFLAGS = -std=gnu99 \
+ $(if $($(*F)_no_Wformat),-Wno-format,-Wformat=2)
+ BUILT_RPATH = \$$ORIGIN/../libasm:\$$ORIGIN/../libdw:\$$ORIGIN/../backends:\$$ORIGIN/../libelf
+ endif
+Index: elfutils-0.127/backends/Makefile.am
+===================================================================
+--- elfutils-0.127.orig/backends/Makefile.am 2007-04-05 10:12:36.000000000 +0100
++++ elfutils-0.127/backends/Makefile.am 2008-03-26 10:45:54.000000000 +0000
+@@ -30,7 +30,7 @@
+ else
+ AM_CFLAGS =
+ endif
+-AM_CFLAGS += -fpic -Wall -Wshadow -Werror -Wunused -Wextra -Wformat=2 \
++AM_CFLAGS += -fpic -Wshadow -Wunused -Wformat=2 \
+ -std=gnu99
+ INCLUDES = -I$(srcdir) -I$(top_srcdir)/libebl \
+ -I$(top_srcdir)/libelf -I$(top_srcdir)/libdw \
+Index: elfutils-0.127/libdwfl/Makefile.am
+===================================================================
+--- elfutils-0.127.orig/libdwfl/Makefile.am 2007-04-05 10:12:36.000000000 +0100
++++ elfutils-0.127/libdwfl/Makefile.am 2008-03-26 10:45:54.000000000 +0000
+@@ -32,7 +32,7 @@
+ else
+ AM_CFLAGS =
+ endif
+-AM_CFLAGS += -Wall -Werror -Wshadow -Wunused -Wformat=2 -Wextra -std=gnu99
++AM_CFLAGS += -Wunused -Wformat=2 -std=gnu99
+ INCLUDES = -I. -I$(srcdir) -I$(srcdir)/../libelf -I$(srcdir)/../libebl \
+ -I$(srcdir)/../libdw -I.. -I$(srcdir)/../lib
+ VERSION = 1
+Index: elfutils-0.127/src/Makefile.am
+===================================================================
+--- elfutils-0.127.orig/src/Makefile.am 2008-03-26 10:48:00.000000000 +0000
++++ elfutils-0.127/src/Makefile.am 2008-03-26 10:48:21.000000000 +0000
+@@ -32,7 +32,6 @@
+ AM_CFLAGS =
+ endif
+ AM_CFLAGS += -Wall -Wshadow -std=gnu99 $(native_ld_cflags) \
+- $(if $($(*F)_no_Werror),,-Werror) \
+ $(if $($(*F)_no_Wunused),,-Wunused -Wextra) \
+ $(if $($(*F)_no_Wformat),,-Wformat=2) $(CFLAGS_$(*F))
+