summaryrefslogtreecommitdiffstats
path: root/recipes/emacs/files/nostdlib-unwind.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/emacs/files/nostdlib-unwind.patch')
-rw-r--r--recipes/emacs/files/nostdlib-unwind.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/emacs/files/nostdlib-unwind.patch b/recipes/emacs/files/nostdlib-unwind.patch
new file mode 100644
index 0000000000..4200301a3f
--- /dev/null
+++ b/recipes/emacs/files/nostdlib-unwind.patch
@@ -0,0 +1,16 @@
+Fix linking problem:
+undefined reference to `__aeabi_unwind_cpp_pr0'
+undefined reference to `__aeabi_unwind_cpp_pr1'
+Index: emacs/src/Makefile.in
+===================================================================
+--- emacs.orig/src/Makefile.in 2008-08-16 14:20:18.000000000 +0000
++++ emacs/src/Makefile.in 2008-08-16 14:51:25.000000000 +0000
+@@ -443,7 +443,7 @@
+ ask GCC explicitly where to find libgcc.a. */
+
+ #ifndef LINKER
+-#define LINKER $(CC) -nostdlib
++#define LINKER $(CC) -nostdlib -lgcc_s
+ #endif
+
+ #ifndef LIB_GCC