aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/enchant/enchant_1.2.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/enchant/enchant_1.2.5.bb')
-rw-r--r--recipes/enchant/enchant_1.2.5.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/enchant/enchant_1.2.5.bb b/recipes/enchant/enchant_1.2.5.bb
new file mode 100644
index 0000000000..be9082d2af
--- /dev/null
+++ b/recipes/enchant/enchant_1.2.5.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Enchant Spell checker API Library"
+PRIORITY = "optional"
+SECTION = "libs"
+LICENSE = "LGPL"
+DEPENDS = "aspell"
+RDEPENDS = "aspell"
+
+inherit autotools pkgconfig
+
+PR = "r1"
+
+S = "${WORKDIR}/enchant-${PV}"
+
+SRC_URI = "http://www.abisource.com/downloads/enchant/${PV}/enchant-${PV}.tar.gz \
+ file://configure.patch;patch=1"
+
+EXTRA_OECONF = "--with-aspell-prefix=${STAGING_DIR_HOST}${layout_prefix} --enable-aspell --disable-binreloc"
+
+FILES_${PN} = "/usr/bin/* /usr/lib/enchant/*.so /usr/share/enchant /usr/lib/libenchant*.so.*"
+
+do_stage() {
+ oe_runmake install prefix=${STAGING_DIR_HOST}${layout_prefix} \
+ bindir=${STAGING_BINDIR} \
+ includedir=${STAGING_INCDIR} \
+ libdir=${STAGING_LIBDIR} \
+ datadir=${STAGING_DATADIR} \
+ mandir=${STAGING_DIR_HOST}${layout_mandir}
+}