aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/enchant/enchant_1.3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/enchant/enchant_1.3.0.bb')
-rw-r--r--recipes/enchant/enchant_1.3.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/enchant/enchant_1.3.0.bb b/recipes/enchant/enchant_1.3.0.bb
new file mode 100644
index 0000000000..cceceebabf
--- /dev/null
+++ b/recipes/enchant/enchant_1.3.0.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Enchant Spell checker API Library"
+PRIORITY = "optional"
+SECTION = "libs"
+LICENSE = "LGPL"
+DEPENDS = "aspell"
+RDEPENDS = "aspell"
+
+inherit autotools pkgconfig
+
+PR = "r0"
+
+S = "${WORKDIR}/enchant-${PV}"
+
+SRC_URI = "http://www.abisource.com/downloads/enchant/${PV}/enchant-${PV}.tar.gz"
+
+EXTRA_OECONF = "--with-aspell-prefix=${STAGING_DIR_HOST}${layout_prefix} --enable-aspell --disable-binreloc"
+
+export CXXFLAGS += " -L${STAGING_LIBDIR} -lstdc++ "
+
+FILES_${PN} = "/usr/bin/* /usr/lib/enchant/*.so /usr/share/enchant /usr/lib/libenchant*.so.*"
+
+do_stage() {
+ autotools_stage_all
+}