summaryrefslogtreecommitdiffstats
path: root/recipes/espeak/espeak-data_1.37.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/espeak/espeak-data_1.37.bb')
-rw-r--r--recipes/espeak/espeak-data_1.37.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/espeak/espeak-data_1.37.bb b/recipes/espeak/espeak-data_1.37.bb
new file mode 100644
index 0000000000..4dc9aa9882
--- /dev/null
+++ b/recipes/espeak/espeak-data_1.37.bb
@@ -0,0 +1,30 @@
+require espeak.inc
+
+PR = "r0"
+
+inherit native
+
+PACKAGES = "${PN}"
+FILES_${PN} = "${layout_datadir}"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+TARGET_ARCH = "${MACHINE_ARCH}"
+
+do_compile() {
+ # Fixing byte order of phoneme data files
+ cd "${S}/platforms/big_endian"
+ sed -i '/^ *CC *=/d' Makefile
+ sed -i 's/\(.*BYTE_ORDER\)/#undef BYTE_ORDER\n#define BYTE_ORDER BIG_ENDIAN\n\1/' espeak-phoneme-data.c
+ oe_runmake
+ ./espeak-phoneme-data "${S}/espeak-data"
+ cp -f phondata phonindex phontab "${S}/espeak-data"
+}
+
+do_install() {
+ install -d ${D}${layout_datadir}/espeak-data
+ install -m 0644 ${S}/espeak-data/phon* ${D}${layout_datadir}/espeak-data
+}
+
+do_stage() {
+ :
+}