aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/evince/evince_2.23.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/evince/evince_2.23.4.bb')
-rw-r--r--recipes/evince/evince_2.23.4.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes/evince/evince_2.23.4.bb b/recipes/evince/evince_2.23.4.bb
index 052e8cac38..17cb21926a 100644
--- a/recipes/evince/evince_2.23.4.bb
+++ b/recipes/evince/evince_2.23.4.bb
@@ -2,8 +2,8 @@ DESCRIPTION = "Evince is a document viewer for document formats like pdf, ps, dj
LICENSE = "GPL"
SECTION = "x11/office"
DEPENDS = "gnome-icon-theme tiff libxt espgs gnome-doc-utils poppler libxml2 gtk+ gnome-vfs gconf libglade gnome-keyring "
-RDEPENDS = "espgs gnome-icon-theme"
-RRECOMMENDS = "gnome-vfs-plugin-file"
+RDEPENDS_${PN} = "espgs gnome-icon-theme"
+RRECOMMENDS_${PN} = "gnome-vfs-plugin-file"
PR = "r2"
inherit gnome pkgconfig gtk-icon-cache
pace */ .highlight .kp { color: #008800 } /* Keyword.Pseudo */ .highlight .kr { color: #008800; font-weight: bold } /* Keyword.Reserved */ .highlight .kt { color: #888888; font-weight: bold } /* Keyword.Type */ .highlight .m { color: #0000DD; font-weight: bold } /* Literal.Number */ .highlight .s { color: #dd2200; background-color: #fff0f0 } /* Literal.String */ .highlight .na { color: #336699 } /* Name.Attribute */ .highlight .nb { color: #003388 } /* Name.Builtin */ .highlight .nc { color: #bb0066; font-weight: bold } /* Name.Class */ .highlight .no { color: #003366; font-weight: bold } /* Name.Constant */ .highlight .nd { color: #555555 } /* Name.Decorator */ .highlight .ne { color: #bb0066; font-weight: bold } /* Name.Exception */ .highlight .nf { color: #0066bb; font-weight: bold } /* Name.Function */ .highlight .nl { color: #336699; font-style: italic } /* Name.Label */ .highlight .nn { color: #bb0066; font-weight: bold } /* Name.Namespace */ .highlight .py { color: #336699; font-weight: bold } /* Name.Property */ .highlight .nt { color: #bb0066; font-weight: bold } /* Name.Tag */ .highlight .nv { color: #336699 } /* Name.Variable */ .highlight .ow { color: #008800 } /* Operator.Word */ .highlight .w { color: #bbbbbb } /* Text.Whitespace */ .highlight .mb { color: #0000DD; font-weight: bold } /* Literal.Number.Bin */ .highlight .mf { color: #0000DD; font-weight: bold } /* Literal.Number.Float */ .highlight .mh { color: #0000DD; font-weight: bold } /* Literal.Number.Hex */ .highlight .mi { color: #0000DD; font-weight: bold } /* Literal.Number.Integer */ .highlight .mo { color: #0000DD; font-weight: bold } /* Literal.Number.Oct */ .highlight .sa { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Affix */ .highlight .sb { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Backtick */ .highlight .sc { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Char */ .highlight .dl { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Delimiter */ .highlight .sd { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Doc */ .highlight .s2 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Double */ .highlight .se { color: #0044dd; background-color: #fff0f0 } /* Literal.String.Escape */ .highlight .sh { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Heredoc */ .highlight .si { color: #3333bb; background-color: #fff0f0 } /* Literal.String.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */ }
#! /bin/sh

# Wipe out all of the sysroots and all of the stamps that populated it.
# Author: Ross Burton <ross.burton@intel.com>
#
# Copyright (c) 2012 Intel Corporation
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License version 2 as
# published by the Free Software Foundation.
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
# See the GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA

set -e

if [ $# -gt 0 ]; then
    echo "Wipe all sysroots and sysroot-related stamps for the current build directory." >&2
    echo "Usage: $0" >&2
    exit 1
fi

ENVS=`mktemp --suffix -wipe-sysroot-envs`
bitbake -p -e > $ENVS

eval `grep -F SSTATE_MANIFESTS= $ENVS`
eval `grep -F STAGING_DIR= $ENVS`
eval `grep -F STAMPS_DIR= $ENVS`
rm -f $ENVS

if [ -z "$SSTATE_MANIFESTS" -o -z "$STAGING_DIR" -o -z "$STAMPS_DIR" ]; then
    echo "Could not determine SSTATE_MANIFESTS/STAGING_DIR/STAMPS_DIR from bitbake, check above for errors"
    exit 1
fi

echo "Deleting the sysroots in $STAGING_DIR, and selected stamps in $SSTATE_MANIFESTS and $STAMPS_DIR."

# The sysroots themselves
rm -rf $STAGING_DIR

# The stamps that said the sysroot was populated
rm -rf $STAMPS_DIR/*/*/*.do_populate_sysroot.*
rm -rf $STAMPS_DIR/*/*/*.do_populate_sysroot_setscene.*
rm -rf $STAMPS_DIR/*/*/*.do_packagedata.*
rm -rf $STAMPS_DIR/*/*/*.do_packagedata_setscene.*

# The sstate manifests
rm -rf $SSTATE_MANIFESTS/manifest-*.populate-sysroot