aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/evtest/evtest_1.23.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/evtest/evtest_1.23.bb')
-rw-r--r--recipes/evtest/evtest_1.23.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/evtest/evtest_1.23.bb b/recipes/evtest/evtest_1.23.bb
new file mode 100644
index 0000000000..4c5d195277
--- /dev/null
+++ b/recipes/evtest/evtest_1.23.bb
@@ -0,0 +1,21 @@
+# Copyright (C) 2009 Khem Raj <raj.khem@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "Event device test program"
+AUTHOR = "Vojtech Pavlik <vojtech@suse.cz>"
+SECTION = "console/utils"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+PR = "r0"
+
+SRC_URI = "http://beagleboard.googlecode.com/files/evtest.c"
+S = "${WORKDIR}"
+
+do_compile() {
+ ${CC} evtest.c -o evtest -I${STAGING_INCDIR} -L${STAGING_LIBDIR}
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 evtest ${D}${bindir}
+}