aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/exalt/exalt-module_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/exalt/exalt-module_svn.bb')
-rw-r--r--recipes/exalt/exalt-module_svn.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/exalt/exalt-module_svn.bb b/recipes/exalt/exalt-module_svn.bb
new file mode 100644
index 0000000000..0a28a1a206
--- /dev/null
+++ b/recipes/exalt/exalt-module_svn.bb
@@ -0,0 +1,19 @@
+require exalt.inc
+
+DEPENDS = "edbus libexalt-dbus"
+RDEPENDS_${PN} = "exalt"
+
+SRC_URI += "file://autotools-fix.patch;patch=1;minrev=78"
+
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
+
+FILES_${PN} += "${libdir}/enlightenment/modules/module_exalt/*.edj \
+ ${libdir}/enlightenment/modules/module_exalt/*/*.so \
+ ${libdir}/enlightenment/modules/module_exalt/*.desktop \
+ ${libdir}/enlightenment/modules/module_exalt/module_exalt"
+FILES_${PN}-dev += "${libdir}/enlightenment/modules/module_exalt/*/*.a \
+ ${libdir}/enlightenment/modules/module_exalt/*/*.la"
+FILES_${PN}-dbg += "${libdir}/enlightenment/modules/module_exalt/*/.debug"
+FILES_${PN}-locale += "${libdir}/enlightenment/modules/module_exalt/locale"
+
+EXALT_MODULE = "module"