aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/expat/expat_1.95.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/expat/expat_1.95.7.bb')
-rw-r--r--recipes/expat/expat_1.95.7.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/expat/expat_1.95.7.bb b/recipes/expat/expat_1.95.7.bb
new file mode 100644
index 0000000000..7b48305933
--- /dev/null
+++ b/recipes/expat/expat_1.95.7.bb
@@ -0,0 +1,26 @@
+require expat.inc
+PR = "r2"
+
+SRC_URI += "file://autotools.patch;patch=1 \
+ file://expat-XMLCALL.patch;patch=1 \
+ "
+
+inherit lib_package
+
+do_configure () {
+ rm -f ${S}/conftools/libtool.m4
+ autotools_do_configure
+}
+
+do_stage () {
+ install -m 0644 ${S}/lib/expat.h ${STAGING_INCDIR}/
+ oe_libinstall -so libexpat ${STAGING_LIBDIR}
+}
+
+do_install () {
+ oe_runmake prefix="${D}${prefix}" \
+ bindir="${D}${bindir}" \
+ libdir="${D}${libdir}" \
+ includedir="${D}${includedir}" \
+ install
+}