aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/expat
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/expat')
-rw-r--r--recipes/expat/expat-1.95.7/autotools.patch13
-rw-r--r--recipes/expat/expat-1.95.7/expat-XMLCALL.patch17
-rw-r--r--recipes/expat/expat-2.0.0/autotools.patch13
-rw-r--r--recipes/expat/expat-native_1.95.7.bb4
-rw-r--r--recipes/expat/expat.inc13
-rw-r--r--recipes/expat/expat_1.95.6.bb16
-rw-r--r--recipes/expat/expat_1.95.7.bb26
-rw-r--r--recipes/expat/expat_2.0.0.bb27
8 files changed, 129 insertions, 0 deletions
diff --git a/recipes/expat/expat-1.95.7/autotools.patch b/recipes/expat/expat-1.95.7/autotools.patch
new file mode 100644
index 0000000000..f22b2401c8
--- /dev/null
+++ b/recipes/expat/expat-1.95.7/autotools.patch
@@ -0,0 +1,13 @@
+--- expat-1.95.7/configure.in~autotools 2004-05-13 22:46:28.000000000 -0400
++++ expat-1.95.7/configure.in 2004-05-13 22:46:39.000000000 -0400
+@@ -50,9 +50,7 @@
+
+ AC_CONFIG_HEADER(expat_config.h)
+
+-sinclude(conftools/libtool.m4)
+-sinclude(conftools/ac_c_bigendian_cross.m4)
+-
++
+ AC_LIBTOOL_WIN32_DLL
+ AC_PROG_LIBTOOL
+
diff --git a/recipes/expat/expat-1.95.7/expat-XMLCALL.patch b/recipes/expat/expat-1.95.7/expat-XMLCALL.patch
new file mode 100644
index 0000000000..c688f06426
--- /dev/null
+++ b/recipes/expat/expat-1.95.7/expat-XMLCALL.patch
@@ -0,0 +1,17 @@
+---
+ lib/expat.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: expat-1.95.7/lib/expat.h
+===================================================================
+--- expat-1.95.7.orig/lib/expat.h 2008-07-31 15:56:39.000000000 -0700
++++ expat-1.95.7/lib/expat.h 2008-07-31 15:58:38.000000000 -0700
+@@ -45,7 +45,7 @@
+ #ifndef XMLCALL
+ #if defined(XML_USE_MSC_EXTENSIONS)
+ #define XMLCALL __cdecl
+-#elif defined(__GNUC__)
++#elif defined(__GNUC__) && defined(__i386) && !defined(__INTEL_COMPILER)
+ #define XMLCALL __attribute__((cdecl))
+ #else
+ /* For any platform which uses this definition and supports more than
diff --git a/recipes/expat/expat-2.0.0/autotools.patch b/recipes/expat/expat-2.0.0/autotools.patch
new file mode 100644
index 0000000000..77aee3a833
--- /dev/null
+++ b/recipes/expat/expat-2.0.0/autotools.patch
@@ -0,0 +1,13 @@
+diff -bur expat-2.0.0~orig/configure.in expat-2.0.0/configure.in
+--- expat-2.0.0~orig/configure.in 2006-01-10 19:10:46.000000000 -0600
++++ expat-2.0.0/configure.in 2006-02-10 19:12:24.000000000 -0600
+@@ -50,9 +50,6 @@
+
+ AC_CONFIG_HEADER(expat_config.h)
+
+-sinclude(conftools/libtool.m4)
+-sinclude(conftools/ac_c_bigendian_cross.m4)
+-
+ AC_LIBTOOL_WIN32_DLL
+ AC_PROG_LIBTOOL
+
diff --git a/recipes/expat/expat-native_1.95.7.bb b/recipes/expat/expat-native_1.95.7.bb
new file mode 100644
index 0000000000..edfa53ae48
--- /dev/null
+++ b/recipes/expat/expat-native_1.95.7.bb
@@ -0,0 +1,4 @@
+SECTION = "libs"
+require expat_${PV}.bb
+inherit native
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/expat-${PV}"
diff --git a/recipes/expat/expat.inc b/recipes/expat/expat.inc
new file mode 100644
index 0000000000..6d27b77b19
--- /dev/null
+++ b/recipes/expat/expat.inc
@@ -0,0 +1,13 @@
+DESCRIPTION = "Jim Clarkes XML parser library."
+HOMEPAGE = "http://expat.sf.net/"
+SECTION = "libs"
+LICENSE = "MIT"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/expat/expat-${PV}.tar.gz \
+ "
+S = "${WORKDIR}/expat-${PV}"
+
+export LTCC = "${CC}"
+
+inherit autotools
+
diff --git a/recipes/expat/expat_1.95.6.bb b/recipes/expat/expat_1.95.6.bb
new file mode 100644
index 0000000000..576ad76a55
--- /dev/null
+++ b/recipes/expat/expat_1.95.6.bb
@@ -0,0 +1,16 @@
+require expat.inc
+
+PR = "r1"
+
+do_stage () {
+ install -m 0644 ${S}/lib/expat.h ${STAGING_INCDIR}/
+ oe_libinstall -so libexpat ${STAGING_LIBDIR}/
+}
+
+do_install () {
+ oe_runmake prefix="${D}${prefix}" \
+ bindir="${D}${bindir}" \
+ libdir="${D}${libdir}" \
+ includedir="${D}${includedir}" \
+ install
+}
diff --git a/recipes/expat/expat_1.95.7.bb b/recipes/expat/expat_1.95.7.bb
new file mode 100644
index 0000000000..7b48305933
--- /dev/null
+++ b/recipes/expat/expat_1.95.7.bb
@@ -0,0 +1,26 @@
+require expat.inc
+PR = "r2"
+
+SRC_URI += "file://autotools.patch;patch=1 \
+ file://expat-XMLCALL.patch;patch=1 \
+ "
+
+inherit lib_package
+
+do_configure () {
+ rm -f ${S}/conftools/libtool.m4
+ autotools_do_configure
+}
+
+do_stage () {
+ install -m 0644 ${S}/lib/expat.h ${STAGING_INCDIR}/
+ oe_libinstall -so libexpat ${STAGING_LIBDIR}
+}
+
+do_install () {
+ oe_runmake prefix="${D}${prefix}" \
+ bindir="${D}${bindir}" \
+ libdir="${D}${libdir}" \
+ includedir="${D}${includedir}" \
+ install
+}
diff --git a/recipes/expat/expat_2.0.0.bb b/recipes/expat/expat_2.0.0.bb
new file mode 100644
index 0000000000..0fd825ee24
--- /dev/null
+++ b/recipes/expat/expat_2.0.0.bb
@@ -0,0 +1,27 @@
+require expat.inc
+PR = "r2"
+
+SRC_URI += "file://autotools.patch;patch=1"
+
+inherit lib_package
+
+do_configure() {
+ rm -f ${S}/conftools/libtool.m4
+ touch ${S}/conftools/libtool.m4
+ autotools_do_configure
+}
+
+do_stage() {
+ install -m 0644 ${S}/lib/expat.h ${STAGING_INCDIR}/
+ install -m 0644 ${S}/lib/expat_external.h ${STAGING_INCDIR}/
+ oe_libinstall -so libexpat ${STAGING_LIBDIR}
+}
+
+do_install() {
+ oe_runmake prefix="${D}${prefix}" \
+ bindir="${D}${bindir}" \
+ libdir="${D}${libdir}" \
+ includedir="${D}${includedir}" \
+ man1dir="${D}${mandir}/man1" \
+ install
+}