aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/faad2/faad2-2.0
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/faad2/faad2-2.0')
-rw-r--r--recipes/faad2/faad2-2.0/Makefile.am3
-rw-r--r--recipes/faad2/faad2-2.0/faad2-gcc-fix.patch11
2 files changed, 14 insertions, 0 deletions
diff --git a/recipes/faad2/faad2-2.0/Makefile.am b/recipes/faad2/faad2-2.0/Makefile.am
new file mode 100644
index 0000000000..dc4f7d9c30
--- /dev/null
+++ b/recipes/faad2/faad2-2.0/Makefile.am
@@ -0,0 +1,3 @@
+SUBDIRS = libfaad common frontend plugins
+
+
diff --git a/recipes/faad2/faad2-2.0/faad2-gcc-fix.patch b/recipes/faad2/faad2-2.0/faad2-gcc-fix.patch
new file mode 100644
index 0000000000..943b89a53f
--- /dev/null
+++ b/recipes/faad2/faad2-2.0/faad2-gcc-fix.patch
@@ -0,0 +1,11 @@
+--- /tmp/mp4ff.c 2006-11-11 21:25:07.000000000 +0100
++++ faad2/common/mp4ff/mp4ff.c 2006-11-11 21:25:20.348554000 +0100
+@@ -87,7 +87,7 @@
+ if (ff) free(ff);
+ }
+
+-static void mp4ff_track_add(mp4ff_t *f)
++void mp4ff_track_add(mp4ff_t *f)
+ {
+ f->total_tracks++;
+