aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fakeroot/fakeroot-native_1.9.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/fakeroot/fakeroot-native_1.9.6.bb')
-rw-r--r--recipes/fakeroot/fakeroot-native_1.9.6.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/fakeroot/fakeroot-native_1.9.6.bb b/recipes/fakeroot/fakeroot-native_1.9.6.bb
new file mode 100644
index 0000000000..77d6f58651
--- /dev/null
+++ b/recipes/fakeroot/fakeroot-native_1.9.6.bb
@@ -0,0 +1,21 @@
+require fakeroot_${PV}.bb
+
+RDEPENDS="util-linux-native"
+
+SRC_URI += "file://fix-prefix.patch;patch=1 "
+S = "${WORKDIR}/fakeroot-${PV}"
+
+inherit native
+
+EXTRA_OECONF = " --program-prefix="
+
+# Compatability for the rare systems not using or having SYSV
+python () {
+ if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
+ bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
+}
+
+do_stage_append () {
+ oe_libinstall -so libfakeroot ${STAGING_LIBDIR}/libfakeroot/
+}
+