summaryrefslogtreecommitdiffstats
path: root/recipes/fakeroot/fakeroot_1.9.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/fakeroot/fakeroot_1.9.6.bb')
-rw-r--r--recipes/fakeroot/fakeroot_1.9.6.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/fakeroot/fakeroot_1.9.6.bb b/recipes/fakeroot/fakeroot_1.9.6.bb
new file mode 100644
index 0000000000..aaf696d79d
--- /dev/null
+++ b/recipes/fakeroot/fakeroot_1.9.6.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Gives a fake root environment"
+HOMEPAGE = "http://fakeroot.alioth.debian.org/"
+SECTION = "base"
+LICENSE = "GPL"
+# fakeroot needs getopt which is provided by the util-linux package
+RDEPENDS = "util-linux"
+PR = "r1"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.tar.gz \
+ file://configure-libtool.patch;patch=1"
+
+inherit autotools
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/fakeroot
+ install -m 644 *.h ${STAGING_INCDIR}/fakeroot
+ autotools_stage_all
+}