aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fam/fam_2.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/fam/fam_2.7.0.bb')
-rw-r--r--recipes/fam/fam_2.7.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/fam/fam_2.7.0.bb b/recipes/fam/fam_2.7.0.bb
new file mode 100644
index 0000000000..653aea6d3c
--- /dev/null
+++ b/recipes/fam/fam_2.7.0.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "File Alteration Monitor"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL"
+
+SRC_URI = "ftp://oss.sgi.com/projects/fam/download/stable/fam-${PV}.tar.gz \
+ file://compile-fix.patch;patch=1"
+
+inherit autotools
+
+CPPFLAGS_append = " -DNDEBUG"
+
+do_stage() {
+ oe_libinstall -so -a -C lib libfam ${STAGING_LIBDIR}/
+ install -m 0644 ${S}/include/fam.h ${STAGING_INCDIR}/
+}
+