summaryrefslogtreecommitdiffstats
path: root/recipes/fbgrab/fbgrab-viewer-native_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/fbgrab/fbgrab-viewer-native_1.0.bb')
-rw-r--r--recipes/fbgrab/fbgrab-viewer-native_1.0.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/fbgrab/fbgrab-viewer-native_1.0.bb b/recipes/fbgrab/fbgrab-viewer-native_1.0.bb
new file mode 100644
index 0000000000..2494918c31
--- /dev/null
+++ b/recipes/fbgrab/fbgrab-viewer-native_1.0.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Viewer for a network enabled fbgrab"
+HOMEPAGE = "http://svn.openezx.org/trunk/src/userspace/fbgrab/"
+LICENSE = "GPL"
+SECTION = "console/network"
+DEPENDS = "libpng-native"
+PV = "0.0+svn${SRCDATE}"
+PR = "r30"
+
+SRC_URI = "svn://svn.openezx.org/trunk/src/userspace;module=fbgrab;proto=http"
+S = "${WORKDIR}/fbgrab"
+
+inherit native
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LDFLAGS} -g -Wall -lpng -lX11 -o fbgrab-viewer fbgrab-viewer.c
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0755 fbgrab-viewer ${DEPLOY_DIR_IMAGE}/fbgrab-viewer
+}
+
+do_stage() {
+ :
+}
+
+do_install() {
+ :
+}
+
+addtask deploy before do_install after do_compile