aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fbprogress
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/fbprogress')
-rw-r--r--recipes/fbprogress/fbprogress_1.1.bb19
1 files changed, 11 insertions, 8 deletions
diff --git a/recipes/fbprogress/fbprogress_1.1.bb b/recipes/fbprogress/fbprogress_1.1.bb
index 8d603b8a3e..855d1ca3d4 100644
--- a/recipes/fbprogress/fbprogress_1.1.bb
+++ b/recipes/fbprogress/fbprogress_1.1.bb
@@ -3,8 +3,8 @@ AUTHOR = "Angel Roman"
HOMEPAGE = "http://www.buglabs.net/"
LICENSE = "GPL"
DEPENDS = "freetype zlib virtual/kernel"
-SRCREV = "9118"
-PR = "r1"
+SRCREV = "9405"
+PR = "r2"
SRC_URI = "svn://svn.buglabs.net/bug/trunk;module=com.buglabs.bug.native.fbprogress;proto=svn \
file://fbprogress-init"
@@ -13,14 +13,17 @@ S = "${WORKDIR}/com.buglabs.bug.native.fbprogress"
inherit update-rc.d
-EXTRA_OEMAKE = "BUG_LINUX_SRC=${STAGING_KERNEL_DIR}"
+TARGET_CXXFLAGS += "-I${STAGING_INCDIR}/freetype2 -I${STAGING_KERNEL_DIR}/include"
+TARGET_LDFLAGS += "-L${STAGING_LIBDIR} -lfreetype -lz"
do_install() {
- install -d ${D}/${sysconfdir}/fbprogress
- install -m 0644 ${S}/images/* ${D}/${sysconfdir}/fbprogress/
- install -d ${D}${layout_bindir}
- install -m 0755 fbprogress ${D}${layout_bindir}
- install -m 0755 fbprogress.sh ${D}${layout_bindir}
+ install -d ${D}/${datadir}/fbprogress
+ install -m 0644 ${S}/images/* ${D}/${datadir}/fbprogress/
+
+ install -d ${D}${bindir}
+ install -m 0755 fbprogress ${D}${bindir}
+ install -m 0755 fbprogress.sh ${D}${bindir}
+
install -d ${D}/${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/fbprogress-init ${D}/${sysconfdir}/init.d/fbprogress
}