aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ffmpeg/omapfbplay-xv_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ffmpeg/omapfbplay-xv_git.bb')
-rw-r--r--recipes/ffmpeg/omapfbplay-xv_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/ffmpeg/omapfbplay-xv_git.bb b/recipes/ffmpeg/omapfbplay-xv_git.bb
new file mode 100644
index 0000000000..3e676e92bb
--- /dev/null
+++ b/recipes/ffmpeg/omapfbplay-xv_git.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Simple ffmpeg-based player that uses the omapfb overlays"
+DEPENDS = "libxv bzip2 lame ffmpeg virtual/kernel"
+LICENSE = "MIT"
+
+PR = "r1"
+PV = "0.0+${PR}+gitr${SRCREV}"
+
+SRCREV = "e66bf25df1f1ff085e6db102b282d90e7ceff4bf"
+SRC_URI = "git://git.mansr.com/omapfbplay;protocol=git \
+"
+
+S = "${WORKDIR}/git"
+
+# We want a kernel header for armv7a, but we don't want to make mplayer machine specific for that
+STAGING_KERNEL_DIR = "${STAGING_DIR}/${MACHINE_ARCH}${TARGET_VENDOR}-${TARGET_OS}/kernel"
+
+CFLAGS += " -I. -I${STAGING_KERNEL_DIR}/include "
+
+do_compile() {
+ cp ${STAGING_KERNEL_DIR}/arch/arm/plat-omap/include/mach/omapfb.h ${S} || true
+ cp ${STAGING_KERNEL_DIR}/include/asm-arm/arch-omap/omapfb.h ${S} || true
+ cp ${STAGING_KERNEL_DIR}/include/linux/omapfb.h ${S} || true
+ oe_runmake OMAPFB=y XV=y NETSYNC=y -e
+}
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/omapfbplay ${D}/${bindir}/omapfbplay-xv
+}