summaryrefslogtreecommitdiffstats
path: root/recipes/ffmpeg
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ffmpeg')
-rw-r--r--recipes/ffmpeg/ffmpeg.inc2
-rw-r--r--recipes/ffmpeg/ffmpeg_0.5.bb5
2 files changed, 5 insertions, 2 deletions
diff --git a/recipes/ffmpeg/ffmpeg.inc b/recipes/ffmpeg/ffmpeg.inc
index be67e61250..4352339119 100644
--- a/recipes/ffmpeg/ffmpeg.inc
+++ b/recipes/ffmpeg/ffmpeg.inc
@@ -32,6 +32,8 @@ EXTRA_OECONF = "\
\
"
+EXTRA_OECONF_append_powerpc += "--${@['disable-altivec','enable-altivec'][bb.data.getVar('BASE_PACKAGE_ARCH',d,1) in ['ppce600']]}"
+
FFMPEG_LIBS = "libavcodec libavdevice libavformat \
libavutil libpostproc libswscale libavfilter"
diff --git a/recipes/ffmpeg/ffmpeg_0.5.bb b/recipes/ffmpeg/ffmpeg_0.5.bb
index d24ff145b9..07af21d04c 100644
--- a/recipes/ffmpeg/ffmpeg_0.5.bb
+++ b/recipes/ffmpeg/ffmpeg_0.5.bb
@@ -2,7 +2,7 @@ require ffmpeg.inc
DEPENDS += "schroedinger libgsm"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
DEFAULT_PREFERENCE = "1"
@@ -19,6 +19,7 @@ FULL_OPTIMIZATION_armv7a = "-fexpensive-optimizations -ftree-vectorize -fomit-f
BUILD_OPTIMIZATION = "${FULL_OPTIMIZATION}"
EXTRA_FFCONF_armv7a = "--cpu=cortex-a8"
+CFLAGS_append_armv7a = " -fPIC -DPIC"
EXTRA_FFCONF ?= ""
EXTRA_OECONF = " \
@@ -45,7 +46,7 @@ EXTRA_OECONF = " \
--arch=${TARGET_ARCH} \
--enable-cross-compile \
--extra-cflags="${TARGET_CFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \
- --extra-ldflags="${TARGET_LDFLAGS}" \
+ --extra-ldflags="${TARGET_LDFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \
--enable-hardcoded-tables \
${EXTRA_FFCONF} \
"