aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fftw/benchfft_3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/fftw/benchfft_3.1.bb')
-rw-r--r--recipes/fftw/benchfft_3.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/fftw/benchfft_3.1.bb b/recipes/fftw/benchfft_3.1.bb
new file mode 100644
index 0000000000..7b9a7110cf
--- /dev/null
+++ b/recipes/fftw/benchfft_3.1.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "FFTW benchmarks"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+
+# single precision fftw is called fftwf
+DEPENDS = "fftwf"
+
+SRC_URI = "http://www.fftw.org/benchfft/benchfft-${PV}.tar.gz"
+
+EXTRA_OECONF = "--disable-fortran --enable-single --enable-shared"
+
+inherit autotools pkgconfig
+
+do_compile_prepend() {
+ sed -i -e 's:all-recursive:$(RECURSIVE_TARGETS):g' ${S}/Makefile
+}
+
+do_stage () {
+ autotools_stage_all
+}
+