aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fget/fget_1.3.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/fget/fget_1.3.3.bb')
-rw-r--r--recipes/fget/fget_1.3.3.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/fget/fget_1.3.3.bb b/recipes/fget/fget_1.3.3.bb
new file mode 100644
index 0000000000..165167e6dc
--- /dev/null
+++ b/recipes/fget/fget_1.3.3.bb
@@ -0,0 +1,22 @@
+LICENSE = "BSD"
+DESCRIPTION = "fget is a commandline tool for mirroring \
+remote files via FTP. It was designed as an analog to the \
+GNU wget utility. The fget package includes an FTP client \
+library, so that others can make use of FTP from within \
+their own C programs."
+SECTION = "libs"
+PRIORITY = "optional"
+
+SRC_URI = "ftp://ftp.feep.net/pub/software/fget/fget-${PV}.tar.gz"
+
+inherit autotools
+
+do_configure() {
+ oe_runconf
+}
+
+do_stage() {
+ oe_libinstall -a -C lib libfget ${STAGING_LIBDIR}
+ install -m 0755 lib/libfget.h ${STAGING_INCDIR}/
+}
+