aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/file/file_4.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/file/file_4.18.bb')
-rw-r--r--recipes/file/file_4.18.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/file/file_4.18.bb b/recipes/file/file_4.18.bb
new file mode 100644
index 0000000000..a98c68009e
--- /dev/null
+++ b/recipes/file/file_4.18.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "File attempts to classify files depending \
+on their contents and prints a description if a match is found."
+SECTION = "console/utils"
+LICENSE = "BSD-ADV"
+DEPENDS = "file-native"
+
+SRC_URI = "ftp://ftp.astron.com/pub/file/file-${PV}.tar.gz \
+ file://dump \
+ file://filesystems"
+S = "${WORKDIR}/file-${PV}"
+
+inherit autotools
+
+do_configure_prepend() {
+ sed -i -e 's,$(top_builddir)/src/file,file,' ${S}/magic/Makefile.am
+ cp ${WORKDIR}/dump ${S}/magic/Magdir/
+ cp ${WORKDIR}/filesystems ${S}/magic/Magdir/
+}
+
+do_stage() {
+ autotools_stage_all
+}