aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/file/file_4.21.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/file/file_4.21.bb')
-rw-r--r--recipes/file/file_4.21.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/file/file_4.21.bb b/recipes/file/file_4.21.bb
new file mode 100644
index 0000000000..758f7f36fa
--- /dev/null
+++ b/recipes/file/file_4.21.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "File attempts to classify files depending \
+on their contents and prints a description if a match is found."
+SECTION = "console/utils"
+LICENSE = "BSD-ADV"
+DEPENDS = "file-native"
+
+SRC_URI = "ftp://ftp.fi.debian.org/pub/gentoo/distfiles/file-${PV}.tar.gz"
+S = "${WORKDIR}/file-${PV}"
+
+inherit autotools
+
+do_configure_prepend() {
+ sed -i -e 's,$(top_builddir)/src/file,file,' ${S}/magic/Makefile.am
+}
+
+do_stage() {
+ autotools_stage_all
+}