aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/flashrom/files/makefile-disable-strip.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/flashrom/files/makefile-disable-strip.patch')
-rw-r--r--recipes/flashrom/files/makefile-disable-strip.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/flashrom/files/makefile-disable-strip.patch b/recipes/flashrom/files/makefile-disable-strip.patch
new file mode 100644
index 0000000000..0296e1d99e
--- /dev/null
+++ b/recipes/flashrom/files/makefile-disable-strip.patch
@@ -0,0 +1,18 @@
+--- flashrom/Makefile.orig 2008-10-25 12:13:21.000000000 +0300
++++ flashrom/Makefile 2008-10-25 12:14:04.000000000 +0300
+@@ -17,7 +17,6 @@
+ LDFLAGS = -lpci -lz
+ else
+ LDFLAGS = -lpci -lz
+-STRIP_ARGS = -s
+ endif
+ ifeq ($(OS_ARCH), FreeBSD)
+ CFLAGS += -I/usr/local/include
+@@ -40,7 +39,6 @@
+
+ $(PROGRAM): $(OBJS)
+ $(CC) -o $(PROGRAM) $(OBJS) $(LDFLAGS)
+- $(STRIP) $(STRIP_ARGS) $(PROGRAM)
+
+ flashrom.o: flashrom.c
+ $(CC) -c $(CFLAGS) $(SVNDEF) $(CPPFLAGS) $< -o $@