aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/flashrom/flashrom_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/flashrom/flashrom_svn.bb')
-rw-r--r--recipes/flashrom/flashrom_svn.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/flashrom/flashrom_svn.bb b/recipes/flashrom/flashrom_svn.bb
new file mode 100644
index 0000000000..0c51a5857e
--- /dev/null
+++ b/recipes/flashrom/flashrom_svn.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Flashrom is a simple utility for reading/writing BIOS chips"
+HOMEPAGE = "http://www.coreboot.org/Flashrom"
+LICENSE = "GPL"
+DEPENDS = "zlib pciutils"
+
+PV = "0.0+svnr${SRCREV}"
+PR = "r0"
+
+SRC_URI = " \
+ svn://coreboot.org/repos/trunk/util/;module=flashrom \
+ file://makefile-disable-strip.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/${PN}"
+
+LDFLAGS += "-lpci -lz"
+
+do_install () {
+ install -d "${D}${sbindir}"
+ oe_runmake 'PREFIX=${D}/${prefix}' install
+}