aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/flickcurl/flickcurl_1.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/flickcurl/flickcurl_1.9.bb')
-rw-r--r--recipes/flickcurl/flickcurl_1.9.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/flickcurl/flickcurl_1.9.bb b/recipes/flickcurl/flickcurl_1.9.bb
new file mode 100644
index 0000000000..ea1cdb1974
--- /dev/null
+++ b/recipes/flickcurl/flickcurl_1.9.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "flickcurl is a C libarry for the Flick API"
+SECTION = "libs"
+HOMEPAGE = "http://librdf.org/flickcurl/"
+LICENSE = "LGPL 2.1/GPL 2/Apache 2.0"
+PR = "r0"
+SRC_URI = "http://download.dajobe.org/${PN}/${PN}-${PV}.tar.gz"
+
+DEPENDS = "curl libxml2"
+
+EXTRA_OECONF = "ac_cv_func_vsnprintf=no"
+
+inherit autotools
+
+do_stage() {
+ install -d ${STAGING_INCDIR}
+ install -m 0644 ${D}/usr/include/*.h ${STAGING_INCDIR}
+ oe_libinstall -so libflickcurl ${STAGING_LIBDIR}
+}
+
+LEAD_SONAME = "libflickcurl.so.1"
+
+FILES_${PN} += "${libdir}/libflickcurl.so.*"