aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone/fso-apm_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/freesmartphone/fso-apm_git.bb')
-rw-r--r--recipes/freesmartphone/fso-apm_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/freesmartphone/fso-apm_git.bb b/recipes/freesmartphone/fso-apm_git.bb
new file mode 100644
index 0000000000..a0a57c2f7a
--- /dev/null
+++ b/recipes/freesmartphone/fso-apm_git.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "freesmartphone.org apm compatibility utility"
+AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
+HOMEPAGE = "http://www.freesmartphone.org"
+SECTION = "console"
+LICENSE = "GPLv2"
+PV = "0.0.0+gitr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/python-helpers.git;protocol=git;branch=master"
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 fso-apm/apm ${D}${bindir}
+}
+
+PACKAGE_ARCH_${PN} = "all"
+RDEPENDS_${PN} = "python-dbus frameworkd"
+RCONFLICTS_${PN} = "apm"