aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone/fso-gpsd_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/freesmartphone/fso-gpsd_git.bb')
-rw-r--r--recipes/freesmartphone/fso-gpsd_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/freesmartphone/fso-gpsd_git.bb b/recipes/freesmartphone/fso-gpsd_git.bb
new file mode 100644
index 0000000000..cde1bb65e3
--- /dev/null
+++ b/recipes/freesmartphone/fso-gpsd_git.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "freesmartphone.org gpsd compatibility daemon"
+LICENSE = "GPL"
+SECTION = "network"
+DEPENDS = "dbus-glib"
+PV = "0.8+gitr${SRCREV}"
+PR = "r2"
+
+SRC_URI = "\
+ ${FREESMARTPHONE_GIT}/fso-gpsd.git;protocol=git;branch=master \
+ file://fso-gpsd \
+"
+S = "${WORKDIR}/git"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "fso-gpsd"
+INITSCRIPT_PARAMS = "defaults 35"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/fso-gpsd ${D}${sysconfdir}/init.d/
+}
+
+FILES_${PN} += "${sysconfdir}"
+RDEPENDS_${PN} = "frameworkd"
+RPROVIDES_${PN} = "gpsd"
+# Disabled as we always got gpsd but not fso-gpsd in the fso-image. Needs
+# fixing.
+#RCONFLICTS_${PN} = "gpsd"