aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freesmartphone
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/freesmartphone')
-rw-r--r--recipes/freesmartphone/fso-gsm0710muxd_git.bb2
-rw-r--r--recipes/freesmartphone/fsodatad_git.bb2
-rw-r--r--recipes/freesmartphone/fsodeviced_git.bb4
-rw-r--r--recipes/freesmartphone/fsomusicd_git.bb6
-rw-r--r--recipes/freesmartphone/fsonetworkd_git.bb2
-rw-r--r--recipes/freesmartphone/gsmd2_git.bb2
-rw-r--r--recipes/freesmartphone/opimd-utils_git.bb2
-rw-r--r--recipes/freesmartphone/zhone_git.bb2
8 files changed, 11 insertions, 11 deletions
diff --git a/recipes/freesmartphone/fso-gsm0710muxd_git.bb b/recipes/freesmartphone/fso-gsm0710muxd_git.bb
index aec38f0dbe..6fae6af421 100644
--- a/recipes/freesmartphone/fso-gsm0710muxd_git.bb
+++ b/recipes/freesmartphone/fso-gsm0710muxd_git.bb
@@ -13,7 +13,7 @@ S = "${WORKDIR}/git"
inherit autotools
-RDEPENDS = "dbus dbus-glib"
+RDEPENDS_${PN} = "dbus dbus-glib"
RCONFLICTS = "gsm0710muxd"
RREPLACES = "gsm0710muxd"
diff --git a/recipes/freesmartphone/fsodatad_git.bb b/recipes/freesmartphone/fsodatad_git.bb
index 9892e12e39..1ee76cf0ef 100644
--- a/recipes/freesmartphone/fsodatad_git.bb
+++ b/recipes/freesmartphone/fsodatad_git.bb
@@ -9,4 +9,4 @@ DEPENDS += "\
libxml2 \
mobile-broadband-provider-info \
"
-RDEPENDS += "mobile-broadband-provider-info"
+RDEPENDS_${PN} += "mobile-broadband-provider-info"
diff --git a/recipes/freesmartphone/fsodeviced_git.bb b/recipes/freesmartphone/fsodeviced_git.bb
index e7ea1c0a6a..2ceff82247 100644
--- a/recipes/freesmartphone/fsodeviced_git.bb
+++ b/recipes/freesmartphone/fsodeviced_git.bb
@@ -2,9 +2,9 @@ require cornucopia.inc
inherit fso-plugin
DEPENDS += "alsa-lib libcanberra libfsoresource"
-RDEPENDS += "libcanberra-alsa"
+RDEPENDS_${PN} += "libcanberra-alsa"
# Included in fsodeviced itself now
-# RRECOMMENDS += "fso-alsa-data"
+# RRECOMMENDS_${PN} += "fso-alsa-data"
RPROVIDES_${PN} = "openmoko-alsa-scenarios virtual/alsa-scenarios"
SRCREV = "${FSO_CORNUCOPIA_SRCREV}"
PV = "0.9.0+gitr${SRCPV}"
diff --git a/recipes/freesmartphone/fsomusicd_git.bb b/recipes/freesmartphone/fsomusicd_git.bb
index 2d1de2b56f..e542205e2c 100644
--- a/recipes/freesmartphone/fsomusicd_git.bb
+++ b/recipes/freesmartphone/fsomusicd_git.bb
@@ -1,6 +1,6 @@
require cornucopia.inc
# Seems like bitbake cannot find dynamicaly created package names in
-# gst-plugins.inc. Image creation usually fail with missing RDEPENDS for
+# gst-plugins.inc. Image creation usually fail with missing RDEPENDS_${PN} for
# gst-plugin-mad gst-plugin-flac gst-plugin-wavparse gst-plugin-sid
# so add recipes needed for runtime dependencies manually here
@@ -10,12 +10,12 @@ PV = "0.0.1+gitr${SRCPV}"
PR = "${INC_PR}.3"
PE = "1"
-RDEPENDS += "\
+RDEPENDS_${PN} += "\
#gst-plugins-base
gst-plugin-volume \
gst-plugin-alsa \
"
-RRECOMMENDS += "\
+RRECOMMENDS_${PN} += "\
#gst-plugins-base
gst-plugin-ogg \
gst-plugin-audioconvert \
diff --git a/recipes/freesmartphone/fsonetworkd_git.bb b/recipes/freesmartphone/fsonetworkd_git.bb
index 974ac3ccc7..9c6c7ba73b 100644
--- a/recipes/freesmartphone/fsonetworkd_git.bb
+++ b/recipes/freesmartphone/fsonetworkd_git.bb
@@ -4,4 +4,4 @@ SRCREV = "${FSO_CORNUCOPIA_SRCREV}"
PV = "0.1.0.0+gitr${SRCPV}"
PE = "1"
PR = "${INC_PR}.3"
-RDEPENDS += "iptables"
+RDEPENDS_${PN} += "iptables"
diff --git a/recipes/freesmartphone/gsmd2_git.bb b/recipes/freesmartphone/gsmd2_git.bb
index 12ddac5d32..777a6f5dc4 100644
--- a/recipes/freesmartphone/gsmd2_git.bb
+++ b/recipes/freesmartphone/gsmd2_git.bb
@@ -16,4 +16,4 @@ inherit autotools
EXTRA_OECONF = "--disable-tests"
-RDEPENDS = "fso-gsm0710muxd"
+RDEPENDS_${PN} = "fso-gsm0710muxd"
diff --git a/recipes/freesmartphone/opimd-utils_git.bb b/recipes/freesmartphone/opimd-utils_git.bb
index 50fb8f37b5..34d18a0acf 100644
--- a/recipes/freesmartphone/opimd-utils_git.bb
+++ b/recipes/freesmartphone/opimd-utils_git.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Test scripts for freesmartphone.org opimd interface"
HOMEPAGE = "http://freesmartphone.org"
SHR_RELEASE ?= "shr"
LICENSE ?= "GPL"
-RDEPENDS = "python-elementary python-dbus python-codecs python-shell python python-core python-edbus frameworkd"
+RDEPENDS_${PN} = "python-elementary python-dbus python-codecs python-shell python python-core python-edbus frameworkd"
SECTION = "x11/application"
SRCREV = "98ccc66d1e0e5e74bd8ea8c761116fb6a1844fc7"
PV = "0.0.3+gitr${SRCPV}"
diff --git a/recipes/freesmartphone/zhone_git.bb b/recipes/freesmartphone/zhone_git.bb
index c1559f4c25..86327bd8a3 100644
--- a/recipes/freesmartphone/zhone_git.bb
+++ b/recipes/freesmartphone/zhone_git.bb
@@ -20,7 +20,7 @@ do_install_append() {
FILES_${PN} += "${datadir} ${sysconfdir}"
-RDEPENDS = "\
+RDEPENDS_${PN} = "\
python-edbus \
python-edje \
python-ecore \