aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fsx-linux/fsx-linux_0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/fsx-linux/fsx-linux_0.0.bb')
-rw-r--r--recipes/fsx-linux/fsx-linux_0.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes/fsx-linux/fsx-linux_0.0.bb b/recipes/fsx-linux/fsx-linux_0.0.bb
new file mode 100644
index 0000000000..294af8fdfd
--- /dev/null
+++ b/recipes/fsx-linux/fsx-linux_0.0.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Asynchronous I/O stress util"
+
+SRC_URI = "http://www.codemonkey.org.uk/projects/fsx/fsx-linux.c"
+
+S = "${WORKDIR}"
+
+do_compile() {
+
+ cd ${S} && ${CC} fsx-linux.c -o fsx-linux -I${STAGING_INCDIR} -L${STAGING_LIBDIR}
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 fsx-linux ${D}${bindir}
+}