aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fuse/fuse-module_2.5.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/fuse/fuse-module_2.5.3.bb')
-rw-r--r--recipes/fuse/fuse-module_2.5.3.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/fuse/fuse-module_2.5.3.bb b/recipes/fuse/fuse-module_2.5.3.bb
new file mode 100644
index 0000000000..f707888c94
--- /dev/null
+++ b/recipes/fuse/fuse-module_2.5.3.bb
@@ -0,0 +1,31 @@
+require fuse.inc
+
+PR = "r0"
+
+SRC_URI += "file://preserve_CC_with_2_4_kernel.patch;patch=1"
+
+S = "${WORKDIR}/fuse-${PV}"
+
+FILES_${PN} = "${base_libdir}/modules"
+
+EXTRA_OECONF = " --enable-kernel-module --with-kernel=${STAGING_KERNEL_DIR}"
+
+inherit module
+
+do_configure() {
+ cd ${S}
+ oe_runconf
+}
+
+do_compile(){
+ LDFLAGS=""
+ cd ${S}/kernel
+ oe_runmake
+}
+
+fakeroot do_install() {
+ LDFLAGS=""
+ cd ${S}/kernel
+ oe_runmake install DESTDIR=${D}
+}
+