aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gabriel/gabriel-native_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gabriel/gabriel-native_svn.bb')
-rw-r--r--recipes/gabriel/gabriel-native_svn.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/recipes/gabriel/gabriel-native_svn.bb b/recipes/gabriel/gabriel-native_svn.bb
new file mode 100644
index 0000000000..a98abb028e
--- /dev/null
+++ b/recipes/gabriel/gabriel-native_svn.bb
@@ -0,0 +1,13 @@
+require gabriel_svn.bb
+inherit native
+DEPENDS = "libssh-native glib-2.0-native dbus-native dbus-glib-native"
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_TOOLS}
+ install -m 0755 src/gabriel ${DEPLOY_DIR_TOOLS}/gabriel-${PV}
+ rm -f ${DEPLOY_DIR_TOOLS}/gabriel
+ ln -sf ./gabriel-${PV} ${DEPLOY_DIR_TOOLS}/gabriel
+}
+
+
+addtask deploy before do_package after do_install