summaryrefslogtreecommitdiffstats
path: root/recipes/gallery
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gallery')
-rw-r--r--recipes/gallery/files/gallery.conf31
-rw-r--r--recipes/gallery/gallery_1.5.5.bb42
2 files changed, 73 insertions, 0 deletions
diff --git a/recipes/gallery/files/gallery.conf b/recipes/gallery/files/gallery.conf
new file mode 100644
index 0000000000..b773e2c24f
--- /dev/null
+++ b/recipes/gallery/files/gallery.conf
@@ -0,0 +1,31 @@
+<IfDefine PHP5>
+
+<Directory /usr/share/apache2/htdocs/gallery>
+
+php_value post_max_size 20971520
+php_value upload_max_filesize 20971520
+php_value magic_quotes_gpc off
+php_value session.save_handler files
+php_value register_globals off
+
+Options -Indexes +FollowSymLinks
+
+<IfModule mod_rewrite.c>
+RewriteEngine On
+RewriteBase /gallery/
+
+# Ensure that the requested gallery is not a valid directory
+# This can cause an infinite redirection loop
+RewriteCond %{REQUEST_FILENAME} !-d
+RewriteRule ^([^\.\?/]+)/([0-9]+)$ /gallery/view_photo.php?set_albumName=$1/index=$2 [QSA]
+RewriteCond %{REQUEST_FILENAME} !-d
+RewriteRule ^([^\.\?/]+)/([A-Za-z_0-9\-]+)$ /gallery/view_photo.php?set_albumName=$1/id=$2 [QSA]
+RewriteCond %{REQUEST_FILENAME} !-d
+RewriteRule ^([^\.\?/]+)/$ /gallery/$1 [R]
+RewriteCond %{REQUEST_FILENAME} !-d
+RewriteRule ^([^\.\?/]+)$ /gallery/view_album.php?set_albumName=$1 [QSA]
+</IfModule>
+
+</Directory>
+
+</IfDefine>
diff --git a/recipes/gallery/gallery_1.5.5.bb b/recipes/gallery/gallery_1.5.5.bb
new file mode 100644
index 0000000000..14c7c0f4e0
--- /dev/null
+++ b/recipes/gallery/gallery_1.5.5.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "The Gallery v1 web image gallery"
+SECTION = "apps"
+LICENSE = "GPL"
+RDEPENDS = "apache2 modphp imagemagick jhead"
+PR = "r2"
+
+SRC_URI = "http://{SOURCEFORGE_MIRROR}/sourceforge/gallery/gallery-${PV}-pl1.tar.gz"
+
+S = "${WORKDIR}/gallery"
+
+inherit autotools
+
+HTTPCONF = "${sysconfdir}/apache2/httpd.conf"
+DEST_DIR = "${datadir}/apache2/htdocs/"
+
+#
+# don't list the albums as a file - it might get auto-deleted
+#
+FILES_${PN} = "${DEST_DIR}/gallery ${sysconfdir}/apache2/modules.d"
+
+
+# No configure step for gallery
+do_configure() {
+ :
+}
+
+# No compile step either
+do_compile() {
+ :
+}
+
+#
+do_install() {
+ mkdir -p ${D}/${DEST_DIR} ${D}${sysconfdir}/apache2/modules.d
+ cp -pPR ${S} ${D}/${DEST_DIR}
+ cp ${FILESDIR}/gallery.conf ${D}${sysconfdir}/apache2/modules.d/95_gallery.conf
+}
+
+# remove the gallery code, but not the albums!
+pkg_postrm_${PN}() {
+ rm -rf ${DEST_DIR}/gallery /${sysconfdir}/apache2/modules.d/95_gallery.conf
+}