summaryrefslogtreecommitdiffstats
path: root/recipes/gammu/gammu_1.24.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gammu/gammu_1.24.0.bb')
-rw-r--r--recipes/gammu/gammu_1.24.0.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes/gammu/gammu_1.24.0.bb b/recipes/gammu/gammu_1.24.0.bb
new file mode 100644
index 0000000000..56a1a91729
--- /dev/null
+++ b/recipes/gammu/gammu_1.24.0.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "GNU All Mobile Managment Utilities"
+SECTION = "console/network"
+DEPENDS = "bluez-libs cmake-native python mysql"
+RDEPENDS_python-${PN} = "python-core"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.gammu.org/"
+PR = "r0"
+
+SRC_URI = "http://dl.cihar.com/gammu/releases/gammu-${PV}.tar.bz2 \
+ file://findmysql.patch;patch=1"
+
+inherit distutils-common-base cmake
+
+PYTHON_DIR = "${@python_dir(d)}"
+
+do_configure() {
+ cd ${S}
+ sed -i 's@^cmake [^$]*\$@cmake -DCMAKE_FIND_ROOT_PATH=${STAGING_DIR_TARGET} $@' configure
+ sed -i 's@\${PYTHON_SITEDIR}@${libdir}/${PYTHON_DIR}/site-packages@g' python/gammu/CMakeLists.txt
+ ./configure --prefix=${prefix} --enable-shared --enable-backup
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+# gammu has a non-standard uninstalled .pc file, which confuses pkgconfig.bbclass.
+# Replace it by custom do_stage_append():
+#do_stage_append () {
+# install -d ${PKG_CONFIG_DIR}
+# cat build-configure/cfg/gammu.pc > ${PKG_CONFIG_DIR}/gammu.pc
+#}
+
+PACKAGES =+ "${PN}-smsd libgammu libgsmsd python-${PN}"
+
+FILES_${PN} = "${bindir}/gammu ${bindir}/jadmaker ${sysconfdir}/bash_completion.d/gammu"
+FILES_${PN}-smsd = "${bindir}/gammu-smsd*"
+FILES_${PN}-dev += "${bindir}/gammu-config ${libdir}/*.so"
+FILES_${PN}-dbg += "${bindir}/.debug ${libdir}/.debug ${libdir}/python*/site-packages/gammu/.debug"
+FILES_libgammu = "${libdir}/libGammu.so.*"
+FILES_libgsmsd = "${libdir}/libgsmsd.so.*"
+FILES_python-${PN} = "${libdir}/${PYTHON_DIR}/site-packages/gammu/*.??"