aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gcc/gcc-4.1.1/sed-fixinc-backslash.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gcc/gcc-4.1.1/sed-fixinc-backslash.patch')
-rw-r--r--recipes/gcc/gcc-4.1.1/sed-fixinc-backslash.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/gcc/gcc-4.1.1/sed-fixinc-backslash.patch b/recipes/gcc/gcc-4.1.1/sed-fixinc-backslash.patch
new file mode 100644
index 0000000000..9aff951bdc
--- /dev/null
+++ b/recipes/gcc/gcc-4.1.1/sed-fixinc-backslash.patch
@@ -0,0 +1,18 @@
+2006-09-06 Matthias Klose <doko@debian.org>
+
+ * Makefile.in (s-macro_list): Conform to POSIX rules in single quoted
+ strings.
+
+--- s/gcc/Makefile.in~ 2008-10-18 08:53:56.000000000 +0100
++++ s/gcc/Makefile.in 2008-10-18 08:55:16.000000000 +0100
+@@ -3146,8 +3146,8 @@
+ macro_list: s-macro_list; @true
+ s-macro_list : $(GCC_PASSES)
+ echo | $(GCC_FOR_TARGET) -E -dM - | \
+- sed -n 's/^#define \([^_][a-zA-Z0-9_]*\).*/\1/p ; \
+- s/^#define \(_[^_A-Z][a-zA-Z0-9_]*\).*/\1/p' | \
++ sed -n -e 's/^#define \([^_][a-zA-Z0-9_]*\).*/\1/p' \
++ -e 's/^#define \(_[^_A-Z][a-zA-Z0-9_]*\).*/\1/p' | \
+ sort -u > tmp-macro_list
+ $(SHELL) $(srcdir)/../move-if-change tmp-macro_list macro_list
+ $(STAMP) s-macro_list